5

Now that the latest update has been pushed, is there a way to install Swype on the Kindle Fire without rooting it?

  • It's not currently possible unless you have root. – eldarerathis Dec 21 '11 at 22:30
  • It's my understanding that you can no longer root with the latest update 6.2.1? – Danny Miller Dec 21 '11 at 22:31
  • Right, so if you've been updated to a stock 6.2.1 it's currently impossible to use Swype. It will install, but there's no way to enable it in the settings (at least, nobody has yet found one and made it public). – eldarerathis Dec 21 '11 at 22:32
2

Still no way without root. (

But I'll post some quick links for root users.

The old method (need to edit settings.db with SQLite Database Browser): http://blog.pathany.com/2011/12/swype-on-kindle-fire.html

New easier methods:

[Guide] Get Swype working without having to edit settings.db

Four simple steps to use alternative keyboards

With Kindle Fire Utility it's rather easy to obtain and revert root.

  • I wound up going with BurritoRoot and then "Get Swype working without having to edit settings.db". Worked like a charm! – Danny Miller Mar 1 '12 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.