13

I know it's a relatively new and unstable application but I figured if anyone has suffered through the issue and solved it then they can help me too.

Anbox does't come with Google Services, As Google Services can't be installed on an Unregistered Device / Firmware, but their are ways to achieve that in Custom Roms or even Emulators, But if you want to use Android to it's fullest then Google Play Services is a must.

What have I tried so far?

I've tried to install Google Play Services x86 apk, which successfully got installed and also appears in Settings > Apps

I've Also tried to install Play Store which also got successfully installed and appear in the App Drawer of Anbox (also In Gnome).

But it Doesn't work like Expected, for example, YouTube app loads content but can't play videos, Google play store doesn't even load content, I think maybe because Google Play Services isn't installed as System app/ or maybe because there are some other g-apps that these things depend on and i'm missing them.

I'm ready to provide more details from my side

  • You could see if Anbox emulates Android's file system somewhere and from there you can see to installing Gapps similarly to how you would do it with custom roms – Hanro50 Jul 12 '17 at 18:49
  • See any Gapps installer script from open gapps used for custom rom and follow the process for anbox – Deepak Gangwar Jul 13 '17 at 23:23
  • This is the script that @Freedom_Ben's answer is basically telling you to run: github.com/geeks-r-us/anbox-playstore-installer There's a pending pull request for a non-snap Anbox too, if that's what you're after. – Oxwivi Oct 10 '18 at 12:31
  • Try that. It worked greately to me on my PC (Ubuntu) and my laptop (Ubuntu) linuxuprising.com/2018/07/… – Sérgio Cabral Apr 1 at 2:02
2

Check out this blog post: http://geeks-r-us.de/2017/08/26/android-apps-auf-dem-linux-desktop/

It is in German but can be translated to English with high levels of success using the Google Translate plugin for Chrome.

For a more detailed discussion, this thread on the projects Github page is helpful: https://github.com/anbox/anbox/issues/118

0

I'm not really sure about Anbox, but I've made and modified several Android distros, that are unregistered, as you had said. What I had done on these devices was:

  1. Either go to Open GApps and then download the app. Then run it, choose the package and wait for it to download. Use a superuser, to grant GApps permission, and allow it to install all Google apps (as per your package selection).
  2. The second thing you can do is, use flashify, to flash a zip that you can download from Open GApps again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.