4

I have added a few words to the personal dictionary in Gboard settings and they aren't working. Trying to create shortcuts for things like my email address, but when I type the shortcut into Gboard, nothing happens.

I've scoured the web for answers to this and have yet to find a solution. I've tried uninstalling and reinstalling Gboard. I emptied the Gboard cache. I'm currently using a Samsung Galaxy S5 and it's on Android 6.0.1, all software is up-to-date. Nothing helps.

How to fix this?

4 Answers 4

2

As noted, special characters may be a problem, but if others have this issue with all shortcuts, clearing Gboard's data (in system settings -> applications -> Gboard) fixed the issue for me.

2
  • 2
    Just needed to clear the cache and force stop; not clear the app data. Dec 21, 2017 at 7:55
  • For me, this worked after I killed the messaging app too.
    – Jay Bose
    Aug 26, 2023 at 23:47
1

It would seem that Gboard has a hard time with shortcuts containing punctuation. Ampersands and colons did not work for me, but shortcuts without these characters work fine.

A little digging on the web would imply that punctuation in shortcuts used to work in previous versions. I'm not sure if this applies to your situation or not, though.

Gboard 6.2.34
Version = 20170404

0

The solution to the problem is as follows.

  1. Visit APK Mirror - Android Keyboard (AOSP) 8.1.0.

  2. Download the AOSP keyboard and install it on your phone.

  3. Enable the AOSP keyboard from the virtual keyboard section in the languages ​​and input section.

  4. Do not set the AOSP keyboard by default. We will use Gboard.

  5. Now go to your personal dictionary in the Languages ​​section. You will see two of your own language.

    For example: For all languages, Turkish, and Turkish (Turkey). Select Turkish and enter your words here and shortcuts are now running, not Turkish (Turkey).

    An error occurs when you enter your words and shortcuts in the dictionary where the language and region are together.

0

My Gboard shortcuts weren't expanding because I had unknowingly been adding a space at the end. I thought I'd added "foo", but I'd added "foo ": that space was the problem. Any time I'd enter "foo " in an app—notice the space—the question to ask yourself is, "which of the following took precedence:"

  1. the confirmation of the end of a word1
  2. or the OS's having confirmed the recognition of my desired shortcut?

(1) had been winning out, trumping (2) and—correctly, unfortunately—winning out over (2) and never allowing (2)'s replacement to happen. As soon as I got rid of the trailing space in my personal dictionary's shortcut replacement string, it worked. It makes sense.

Incidentally, in one of my user-defined dictionary shortcuts, I have the octothorpe, or hashtag, "#" working, too, so it appears that some special characters are also working and now not causing problems. So if this is not new news, please don't shoot the messenger!

1 An additional wrinkle I can't unravel is "is it the app or the OS doing the detection and identification in (1)?" I can't tell—I think I'd have to be able to trace a single step through the kernel to be able to answer that one. (-;

Gboard 12.6.02.491625702-release-arm64-v8a102451622

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .