2

short story is as follows: I have a Sony Xperia M2 with display suffering from water damage. It's completely black but it's still working, booting and responding to touch. However, I need to enter my PIN because the device is encrypted. I want to back up some data before I toss that phone. All I would really need to do is enter the 4 digits, then I'd have access to all the files from my PC, but somehow that doesn't work, I tried it a hundred times blind-typing, but I keep messing it up. Does anybody have a solution for that, or a similar phone and a screenshot that could show me what I am doing wrong? (Trying to type the digits, then hitting lower right "Enter" button. Does not work. I get haptic feedback on the "back" button on the lower left corner and I can do something like emergency call in the top middle of the display.)

Apart from that, I tried to access the phone from my Linux laptop. adb does not work at all, probably because USB debug is disabled. I tried to enter fastboot mode and flash a TWRP recovery image like it has been suggested multiple times here to bypass the USB-debug-issue, with no luck. I get into fastboot mode, fastboot sees the device, but when I try to load the boot image, this message pops up:

creating boot image...
creating boot image - 382976 bytes
downloading 'boot.img'...
OKAY [  0.014s]
booting...
FAILED (status read failed (No such device))
finished. total time: 5.286s

Then the blue LED turns off and gets back to red -> orange, which I assume is nothing but a normal boot.

Does anybody know anything else I could try or why the recovery image does not work? Any suggestion is really much appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.