I rooted my Lineage OS 14.1 but none of my apps ask for root permissions.

I followed the instructions of this link and the root access option in my phone is "apps and adb". Do I miss something?

I have a Moto G4 Plus and I've already tested Sixaxis and ES File Manager, none of them ask for root permissions.

  • 1
    Check SuperSU list, maybe your apps are already there. – Suncatcher Apr 22 '17 at 10:05
  • I didn't installed SuperSu. I didn't find a binary that works with Lineage, just their su pack. The option Manage root access is disable. – victortamotsu Apr 25 '17 at 1:16
  • I had this issue on a Xiaomi Redmi Note 4 cause it's a 64 Bit phone with 64 Bit LineageOs installed. But by mistake I installed the 32 Bit su installed. When doing this, you can enable root in the developer options, but no app can ask for root permission. – Lion Dec 25 '17 at 14:59
  • I am having the same problem. Could you fix it? Did re-flash help? – turururu Mar 25 '18 at 11:17
  • No turururu... I gave up the Lineage and installed the Ressurection Remix (that proved a fast and stable ROM in my case) in my Moto G4 plus. If you solve your case, please comment in this thread for future acknowledge. Thanks! – victortamotsu Mar 26 '18 at 12:36

You have to install the su-arm.zip package from "Extras" in the downloads page, then install it from the recovery, then enable Developer Options and set "Root Access" to Apps and Adb.

  • 1
    -1: "the root access option in my phone is "apps and adb"" - this indicates OP already has the addon pack installed. – Andy Yan Apr 25 '17 at 6:11
  • i thought it might not be installed currectly. you might need to update lineage os to the current update, or install SuperSU or just any other root manager. – Nadav Tasher Apr 25 '17 at 6:33
  • Installing the latest SuperSU will uninstall the 32 bit version and replace it with a correct version for the device, provided you can flash zip files in your recovery. – Gadget Guru Mar 25 '18 at 20:25

Make sure you have the latest version of LineageOS. If you do, go to Settings > Developer Options, and make sure Root Access is on Apps and ADB. Then go to "Manage Root Accesses." There you can control which apps are given root access. It's weird that you don't get promted though, maybe re-flash the OS?

Edit: I just saw a response from you that "manage root accesses" was disabled. Maybe re-flash LineageOS?

Not the answer you're looking for? Browse other questions tagged or ask your own question.