1

When I compose a new message in Gmail on my Android phone I'm offered several suggestions for the recipient (i.e. for the email's To: field) via an autocomplete function. These are often very old/unknown contacts which I'd like to no longer see as autocomplete suggestions, but I can't yet work out how to clear this list.

The contacts suggested appear to have come from an old list of "Other" contacts, i.e. people that I've contacted infrequently and who were not actual contacts I've added to my contact list. These only show up when I compose a new message in Gmail on my phone, and the autocomplete works as expected when on a non-Android device (laptop).

My assumption is that the Gmail autocomplete function is reading these outdated contacts from a list stored somewhere in a file on my phone which is impervious to the contact sync process or somehow not being cleared as expected otherwise -- I've tried all manner of syncing phone contacts, deleting old/other contacts outside of Android, etc. but no joy so far.

An idea I have is to somehow search Android's filesystem for a file that contains the unwanted contacts and if found then wipe that file clean. Is this reasonable, and if so can anyone suggest guidance that'll make this less of a wild goose chase?

My phone details:

Model: Nexus 5X
Android version: 7.1.2
Baseband version: M8994F-2.6.37.2.21
Kernel version: 3.10.73-ge570678
Build version: N2G47F

Thanks in advance for any help or insight.

  • 1
    I think this isn't necessarily phone related, but on Google's end, as the same thing happens to me not only on my device, but when logged into Gmail/Inbox via computer. – DukeSilversJazz Apr 25 '17 at 16:11
  • 1
    Do you know about the "Other" contacts? Do you get the same behavior if you remove these? My hunch is that the contact suggestions I'm seeing on my phone when I compose a new message are from the "Other" contacts list from some point before, and now that that list has been wiped clean there's a problem with getting them cleaned out on the Android device's end. – James Adams Apr 25 '17 at 17:59
  • No, but you may be onto something...I checked there, remove a bunch that I no longer contacted. Seems my device and Inbox on computer are showing the same Contacts for suggested ones. You could try clearing the app's cache, and seeing if that syncs things up, or forcing an Account Sync for you Google Account in the device's Settings - Accounts. – DukeSilversJazz Apr 25 '17 at 20:26
  • Thanks for these suggestions. Unfortunately I already tried these steps before posting my question with no luck, and it actually just added more work to clean out all of the non-phone related contacts off of the phone (I usually don't sync so as to only have phone relevant contacts on my phone), but I guess it was worth a shot. – James Adams Apr 26 '17 at 19:02
  • 1
    this can be done in gmail web, by Going into Settings, and selecting I'll add contacts myself for auto-complete option. But this option does not seems to be present for mobile app. – AADAndroidEnthusiasts May 4 '17 at 18:01
0

In your case, you could try clearing gmail's local data.

Go to

Settings -> Apps -> 3-dot Menu -> Show System

Then Scroll down and Select Gmail. Tap on Storage -> Clear Data.

This should remove anything stored by Gmail locally.

Your Emails and other data will be synced back when you reopen Gmail.

  • Thanks a lot for this suggestion, Albin. Unfortunately it didn't work for me. I've even uninstalled/reinstalled the Gmail app on this phone more than once but still the issue persists. It's looking like it'll take a hard total reset back to factory settings to fix this, and I dread reconfiguring my phone again to get the setup I have in place now. – James Adams May 2 '17 at 14:14
  • If it didn't go after deleting data, then I don't think a hard reset would help. – Albin K C May 6 '17 at 2:53
  • Thanks, Albin. My hunch is that these unwanted contacts are stored someplace in a file on my Android device, as they never appear when I'm using Google services such as Gmail on my laptop. But without rooting my device it's not possible to search very deeply and so I haven't been able to verify this yet. And I'm not about to do a hard factory reset now that everything else on the phone is finally configured like I like it, that took forever. – James Adams May 8 '17 at 14:14
0

I think it should be possible to wipe the autocompletion of unwanted entries by deleting the associated contacts. For that, you should go to https://contacts.google.com/ and search the unwanted contacts. I am not sure if hiding the contact is sufficient or if you have to delete them, but I suppose you can find that out yourself as I want to keep my contacts.

Best regards

  • Thanks, Luca. I've tried this already. The contacts were all in the Other section, I removed these and then synced the phone but nothing changed. – James Adams May 4 '17 at 19:19
0

I have exactly the same issue as the poster above. My contacts have been cleaned out of the old address, the Gmail on the computer does not suggest them but the Gmail app on Android insists to keep showing old email address of someone who changed jobs four times in the last year or so and I communicate with a lot. And I only have his current email address in contacts yet Gmail for Android insists on preferring the older emails, a real pain. Yes all the standard suggestions if cleaning contacts etc are not what this and other posters look for.. but for Google to fix this automatically.

However I did manage to clean it with doing this: Phone > settings > apps > Gmail - force stopped Gmail - storage: cleaned both cache and data - restarted Gmail which first looked as if I was a first time user, but it still know my email address so I could just click next and they all came back. The new is cleaned up

  • In case it's encouraging I thought I'd let you know that I now have a new Google/Project Fi phone (Moto X4, Android 8.1.0) and this problem has disappeared there. So somewhere along the way this seems to have been fixed (or this phone is using an older version of Android that didn't have this new bug?). Thanks for the update -- it's good to know I wasn't the only one frustrated by this enough to post about it here. – James Adams Jun 8 '18 at 15:10
0

Although I'm not very familiar with this issue. But give a try on accounts.google.com-how we collect data. I will personally look into it since I had many expired contacts but never had Gmail recommended me those. Also reset the contacts data from Google's server. That might do it. You are proposing that it may be due to some external sources. Regarding this I can only say that in your phone/devices there might be some VCS files from where these contacts are suggested. That's my guess only though.

  • Thanks for your follow up. I am no longer facing this issue due to replacing my phone and associated updates of Android. – James Adams Jan 29 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.