I have an old Nexus 7 (picked up from I/O 2012) that got unbearably slow after an OTA upgrade to Android 5. After seeing hints from early adopters that Nougat is serviceable on this device, I decided to give it a whirl by following these instructions:

  1. Connect from PC via adb and run:

    adb reboot bootloader
    fastboot oem unlock
    fastboot flash recovery twrp-3.1.0-0-grouper.img
  2. Hold Power + Volume Up to boot into TWRP Recovery Mode.

  3. Advanced Wipe, selecting all partitions.

  4. Advanced | ADB Sideload | then on PC run:

    adb sideload aosp_grouper-7.1.2-ota-eng-20170410.ds.zip
    adb sideload "Mini_Dynamic_GApps-7.1.x-20170121.zip"
  5. Ensure /data is mounted (checkmarked under TWRP's Mount menu).

  6. Still in TWRP, start Terminal and run:

    echo "SYSTEMLESS=true" >/data/.supersu
  7. Another ADB Sideload:

    adb sideload "SR4-SuperSU-v2.78-SR4-20161115184928.zip"
  8. Wipe, selecting Dalvik / ART Cache and cache.

  9. Reboot to system, allowing TWRP to install its app when prompted.

Here are the files I used:

The device booted up and began the setup wizard, but as soon as I tapped an option to either set up a new account or copy data from an existing one, I got the error:

Setup Wizard has stopped

Setup Wizard has stopped

and on repeated attempts:

Setup Wizard keeps stopping

Setup Wizard keeps stopping

After some more research, the consensus seems to be it's a permissions issue with blame ostensibly pointing to the CyanogenMod (presumably now LineageOS) team. I tried a few suggestions below, but I could use some help on how to proceed.

  • Swiping down (notifications bar) or trying other "gesture hacks" to get to some sort of system options page to adjust the permissions for the wizard all fail. The app seems to lock up the device pretty thoroughly into "kiosk" mode.

  • I'd love to try this supposed fix:

    pm grant com.google.android.setupwizard android.permission.READ_PHONE_STATE

    but after booting into the system the device is no longer visible under adb devices. For what it's worth, running the command in a TWRP Terminal doesn't work either (and I'm not sure if it should).

  • Mounting System in TWRP and running df in a Terminal shows the /system partition is 98% full, with 16064 [bytes?] available. I used the same GApps as the guy who wrote the instructions I was following; is it too big?

  • In TWRP I was able to rename /system/priv-app/SetupWizard/SetupWizard.apk to keep it from running, and that at least got me into the system. But I can't figure out how to enable Developer Options / USB Debugging (required for adb) or even a Terminal window for that matter. Tapping repeatedly on Build number in the About Tablet screen does nothing.

  • I could try and grab a Terminal app from Google Play, but I'm hesitant to proceed with setting it up with my credentials under this "Default Owner" profile. Is it safe to skip the initial Android Setup Wizard altogether and just start using the device?

  • I also tried another TWRP Wipe, using the default partitions (Data, Cache, Dalvik).

  • I suppose I could try and sideload a Terminal APK. But... really?

I came here because I didn't want to get too far ahead of myself before getting a second opinion. I tried to document the steps taken so far as thoroughly as possible (as well in part to help others, since the documentation out there in the wild for all this is a bit scattered and confusing). I'm hoping this is just a case of me having missed a small detail in the procedure that someone can point out.


I've done many flash attempts and at the advice of folks here and elsewhere I more recently switched to using:

So instead of Steps 4-7, it's now:

  1. Run on PC:

    adb push lineage-14.1-20170423-UNOFFICIAL-aaopt-grouper.zip /sdcard/
    adb push addonsu-arm-signed.zip /sdcard/
    adb push open_gapps-arm-7.1-pico-20170426.zip /sdcard/
    adb push gapps-config-grouper.txt /sdcard/
  2. Install | Add the three zips (in the same order as listed above).

    Safely ignore the "Updater process ended with signal: 4" and "Error installing the zip file" messages.

I was able to bypass the Setup Wizard - by using either the build.prop tip Andy Yan pointed me to, or the four-corner tapping trick Nadav Tasher suggested in his answer. However I'm still having problems with apps stopping (even those from the Play store). Presently working on identifying and granting missing permissions.

By way of example, while troubleshooting I found com.google.android.setupwizard was missing these requested permissions:


I was able to grant all of them except the last one, but didn't manage to get the wizard to restart afterward so gave up on that (particularly after being told it wasn't that important anyway).

Haven't gotten a chance to do similar analysis on any other apps - and not that inclined to. I feel like if things were working right I shouldn't have to be doing this, and am hoping someone can suggest a better way (e.g. a LineageOS tweak or maybe a different GApps?).

2 Answers 2


Had this problem a couple days ago. Solved it by bypassing the SetupWizard. Steps to skip:

  1. Tap the top-left corner of the screen.

  2. Tap the top-right corner of the screen.

  3. Tap the bottom-right corner of the screen.

  4. Tap the bottom-left corner of the screen.

Repeat this until the SetupWizard skips.

  • Holy smokes what kind of super secret Konami code is this!
    – rkagerer
    Commented Apr 26, 2017 at 10:55
  • did it work for you? Commented Apr 26, 2017 at 11:03
  • It got me past the Setup Wizard. Handy to know. But I'm still getting app crashes from various programs. Seems something is wrong with my installation. Based on what I saw of com.google.android.setupwizard, I think my APK's may not have all their required permissions.
    – rkagerer
    Commented Apr 26, 2017 at 12:45
  • try to give them permissions or update them somehow or reinstall gapps for 7.1.2 Commented Apr 26, 2017 at 12:47
  • Hmm, it's not just the GApps I flashed. Other Google apps I grab from the Play Store (e.g. Google app) are also having similar errors.
    – rkagerer
    Commented Apr 27, 2017 at 3:59

The GAPPS is outdated. Android 7.1.2 introduced changes to the Setup Wizard that will break it for older versions. Use the actively maintained OpenGAPPS instead, with the added benefit of choosing the version (mini, micro, nano, etc.) you want, and also make /system less occupied. Just wipe everything in TWRP and start from where you sideload the ROM and GAPPS.

Also, just a hint: AOSP is clean but lacks features. If you want to fiddle with more customization, there are plenty of choices out there (e.g. LineageOS). You also likely won't need to deal with SuperSU if you flash them, as they have built-in SU management.

  • Thanks, will try that! By the way is that LineageOS build you linked to (2017-03-15) the one I should use, or should I go with the 2017-04-23 one listed here? What does aaopt mean, anyway - is that the maintainer?
    – rkagerer
    Commented Apr 26, 2017 at 6:02
  • 1
    Yup, that's the maintainer. Use the 0423 build (since XDA people reported no major bug) paired with the latest GAPPS so as to avoid bumping into the Setup Wizard issue.
    – Andy Yan
    Commented Apr 26, 2017 at 6:15
  • Apparently adb sideload streams the zip without storing it on the Android device. I'm going to use adb push instead, but if I didn't, I'm curious: How would I supply a gapps-config-grouper.txt and more importantly, where would the installer write logfiles (like open_gapps_log.txt)? It said "Copying Log to /sideload" but nothing was there.
    – rkagerer
    Commented Apr 26, 2017 at 8:11
  • 1
    What are you looking to achieve? You could just install OpenGAPPS without configuring it. Is there an app in the package that you really want gone?
    – Andy Yan
    Commented Apr 26, 2017 at 8:17
  • 1
    Sideload isn't the "mainstream" way to install - usually we have a copy of those packages on the internal storage. That's why CWM/TWRP has "install from storage" upfront but hides "ADB sideload" in a corner.
    – Andy Yan
    Commented Apr 26, 2017 at 8:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .