The issue is that I see a high percentage on the "Android OS" item in the Battery Usage, and I want to find out what is causing it. But let me say that I'm interested in diagnostics techniques and tools, rather than increasing the battery life, as you will see in the below figures that the battery isn't drained much faster than expected.

Here's the situation with the phone right now:

  • Last charged 13 hours ago
  • I restarted the phone after charging it
  • I have switched off everything (such as GPS, WiFi, Data network)
  • I was on a 2G network all the time
  • My only use from the phone during the day was a few minutes of WiFi, receiving two SMS messages, and a call that lasted less than a minute.
  • I have auto-sync turned off

And here's the battery usage stat:

  • Android OS: 67%
  • Display: 10%
  • Cell standby: 9%
  • Phone idle: 6%

The Android OS shows 1 hour and 30 minutes of CPU time, but the total time that the phone was turned on was less than 30 minutes, and I don't have anything active in the background.

The battery level isn't bad at all (80%), but considering that I haven't done anything with the phone (and that the phone has a 2500 mAh battery) I am curious to find out what is causing the battery usage.

Obviously, this should be caused by some background tasks that aren't listed in the battery usage. I am looking for ways, tools, and methods that enables me to diagnose this further and relate the 67% of the usage to actual applications.

Some additional information:

I have a Galaxy Note, with Gingerbread 2.3.6 installed. I have "Usage Timelines Free" installed (which wasn't running during the day), and it doesn't show any excessive CPU usage by any app that can lead me toward who's consuming the battery.

Related question (helpful, but didn't answer my question) : What can cause "Android OS" process to use high percentage of battery?

  • I'm a little bit confused. You had the phone on for less than 30 minutes, but you charged it and restarted it 13 hours ago?
    – Chance
    Commented Dec 30, 2011 at 17:15
  • I charged it and restarted it 13 hours ago, and since then I didn't use it for more than 30 minutes. (But the device wasn't shut down, the screen was off the whole time)
    – Iravanchi
    Commented Dec 30, 2011 at 21:40

3 Answers 3


Use an app such as "Better battery stats". This app provides detailed information about all the services running. This is way better than the stock app for diagnostics.

Additionally, a lot of the core services for the system are attributed as part of the "Android OS". There is a very particular bug in Samsung Galaxy S II devices relating to the TouchWiz calendar that keeps doing a lot of unnecessary checks which prevents the device from sleeping properly when the screen is turned off. This causes a huge drain in battery life. Since the TouchWiz on an S II is very similar to the one on a Galaxy Note, you might have the same inherent bug.

These links might give you a better idea:

  • Thanks, this is actually the way I went. I used the BBS app to find out that there are kernel wake locks preventing deep sleep. Here's detailed explanation on XDA, if you are interested or you can comment on what actually happened: forum.xda-developers.com/showthread.php?t=1419087
    – Iravanchi
    Commented Dec 30, 2011 at 21:37
  • Haha no thanks. Thats all right. My friend and I have already looked into this because he has a Galaxy SII and had this problem. :)
    – Gautham C.
    Commented Dec 31, 2011 at 4:01
  • Well, the issue is still there for me. A kernel wake lock keeps my phone awake, named "GPS" and I figured it is because of Network Location. When I turn network location off, the phone gets to sleep deeply. So if you have any idea regarding this, your help is very much appreciated :)
    – Iravanchi
    Commented Dec 31, 2011 at 6:31
  • hmmm....I am not sure. A lot of touchwiz services reference each other. Maybe Samsung's reuse of code in the different services caused the wakelock issue to be in multiple services? I would suggest looking into the xda forums for your device. The will probably have a good solution for you
    – Gautham C.
    Commented Jan 13, 2012 at 18:49
  • @Iravanchi: AFAIK, this has a fairly easy fix. Maps -> Settings -> Location Settings -> Disable "Location reporting". That prevents nearly all of the battery drain when idle, IIRC. Commented Oct 24, 2012 at 5:36

I think you should re-read the related question.

This is likely down to either OS services or apps left running in the background. I suggest you try something like taskkiller or the taskmanager itself and check which apps are still running in the background. Even if you think you haven't started any, it is likely that the device managed to launch some sync services before you stopped it from syncing.

  • I have a task killer installed, and I see a lot of apps running. Since the services start automatically, I want to know which of them should be held accountable for the battery consumption, so that I can decide on keeping or uninstalling them. And the auto-sync was disabled before I restart my device.
    – Iravanchi
    Commented Dec 24, 2011 at 20:19
  • 2
    Don't use task killers. Android already has a built-in taskkiller that kills apps safely and cleanly. task killer apps tend to brute force kill apps essentially force closing them. They are known to cause system instability in the long run, can actually cause more force closes later down the line and also can be a problem in terms of battery life.
    – Gautham C.
    Commented Dec 30, 2011 at 15:16

I am using Samsung Galaxy R for more than 5 months. Such a wonderful Device, of course the issue is battery life. I have tried many of resources no use. I did factory rest 2 times still no use. After full charge it is draining suddenly to 45% in 4 hours(there was no 3G, wifi,GPS). I was totally frustrated, finally i got a chance to read this forum. There i started to think about GPS wake lock, finally i found the solution Go to Settings, Location and Security, and disable "Use GPS satellites" (make sure your connected to internet)then try to observe. Now please be noted my observation below, from 1am 99% to 6am 97%(fone was in sleep) from 6am 97% to 6pm 85% (normal use). Try this, if it is helping help others to get away from the frustration.

  • 1
    Where are you seeing these settings? I don't have anything under Settings | Security called "remote controls".
    – ale
    Commented Apr 11, 2012 at 1:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .