Okay, so in an attempt to stop the OTA notification, I un-installed System Updates 1.0.0 (com.samsung.apk) using Titanium Backup. Well, that didn't help, so I'm trying to restore the app in-case I ever need to update my Profile or PRL. But, when I try to use Titanium Backup to restore this app, it just sits on the "Restoring..." screen and I have to use the task manager to kill it in order to ever do anything.

  • I've tried both restoring "App only," and "App+Date"
  • I've tried pushing the com.samsung.apk directly to my phone (/system/app/com.samsung.apk) using ADB.

The only idea I have left is to re-flash my phone. Is there anything I can try before reflashing?

Phone Information:

  • Samsung Epic 4G (SPH-D700)
  • Android 2.2.1 (FROYO.EC05)
  • Kernel
  • Titanium Backup 4.6.7 (Free version)
  • Rooted using One Click Root v2.5.5

Answers to questions I know are going to be asked:

  • Q: Why don't you just update?
    A: Because there is something wrong with EI22, and every time I do I lose service until I flash back to EC05
  • Q: Do you have trouble restoring any other apps using Titanium Backup?
    A: No, I tried restoring two other system apps and they restored fine.
  • Q: Did you make sure Debugging Mode was on?
    A: Yes, I tried with it both on and off
  • Q: Why didn't you just "Freeze" it instead of uninstalling it?
    A: Because, the free version of Titanium Backup doesn't allow Freezing, and I just felt like using a GUI method at the time. I didn't really think that un-installing it would be much different than freezing it.

3 Answers 3


If your device is full rooted (not just shell rooted), try using Root Explorer app. Mount /system with read-write permission and then paste com.samsung.apk file in /system/app/.

Reboot the device... Done!

Remember to set permissions of the app to rw-r--r-- before rebooting.


I don't think so, sorry :( but since you have titanium backup, reflashing shouldn't be a very big deal :) There are also some free apps on the market that can freeze other apps https://market.android.com/details?id=com.anttek.am


Based on your situation, if all means does not work, just reflash the firmware via ODIN. You do not have to factory reset (i.e. your data will still be there), but you will lost root. Just perform the steps you used to root your phone before this. I suggested this because certain apps cannot be restored even though you push it via ADB or paste it in the system partition.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .