0

Has just crashed and refused to turn on reliably, gets to white google logo and switches off. Occasionally gets to Fastboot menu, but never gets to recovery menu I suspect battery issue, although I have power cable connected, and was on 70% when it crashed

Erase the current recovery by using fastboot: fastboot erase recovery Flash the recovery.img file using fastboot: fastboot flash recovery recovery.img Now you've flashed a fresh recovery image to your device. You can do this without losing any data, and if you use a custom recovery like TWRP, these instructions apply as well. I do this all the time when I reload the stock software on my Nexus 6.

Running latest Ubuntu GNU/Linux on laptop android-tools-adb 5.1.1r36+git20160322-0ubun android-tools-fastboot 5.1.1r36+git20160322-0ubuntu3

Google LG Nexus 5X, running latest updates.

But isn't showing up as a device I can use by fastboot or adb

$ lsusb
show one extra device:
Bus 003 Device 005: ID 05c6:9008 Qualcomm, Inc. Gobi Wireless Modem (QDL mode)
Apr 29 15:04:59 ubuntu1404 kernel: [157627.493587] usb 3-1: new high-speed USB device number 6 using xhci_hcd
Apr 29 15:05:04 ubuntu1404 kernel: [157632.606057] usb 3-1: device descriptor read/64, error -110
Apr 29 15:05:19 ubuntu1404 kernel: [157647.823323] usb 3-1: device descriptor read/64, error -110
Apr 29 15:05:19 ubuntu1404 kernel: [157648.039307] usb 3-1: new high-speed USB device number 7 using xhci_hcd
Apr 29 15:05:25 ubuntu1404 kernel: [157653.151722] usb 3-1: device descriptor read/64, error -110
Apr 29 15:05:35 ubuntu1404 kernel: [157663.392584] usb 3-1: new high-speed USB device number 8 using xhci_hcd
Apr 29 15:05:40 ubuntu1404 kernel: [157668.505031] usb 3-1: device descriptor read/64, error -110
Apr 29 15:05:55 ubuntu1404 kernel: [157683.722224] usb 3-1: device descriptor read/64, error -110
Apr 29 15:05:55 ubuntu1404 kernel: [157683.938212] usb 3-1: new high-speed USB device number 9 using xhci_hcd
Apr 29 15:06:00 ubuntu1404 kernel: [157689.050650] usb 3-1: device descriptor read/64, error -110
Apr 29 15:06:16 ubuntu1404 kernel: [157704.267841] usb 3-1: device descriptor read/64, error -110
Apr 29 15:06:16 ubuntu1404 kernel: [157704.483826] usb 3-1: new high-speed USB device number 10 using xhci_hcd
Apr 29 15:06:21 ubuntu1404 kernel: [157709.500278] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
Apr 29 15:06:26 ubuntu1404 kernel: [157714.716594] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
Apr 29 15:06:26 ubuntu1404 kernel: [157714.920605] usb 3-1: device not accepting address 10, error -62
Apr 29 15:06:26 ubuntu1404 kernel: [157715.032581] usb 3-1: new high-speed USB device number 11 using xhci_hcd
Apr 29 15:06:31 ubuntu1404 kernel: [157720.045014] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
Apr 29 15:06:37 ubuntu1404 kernel: [157725.261441] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
Apr 29 15:06:37 ubuntu1404 kernel: [157725.465430] usb 3-1: device not accepting address 11, error -62
Apr 29 15:06:37 ubuntu1404 kernel: [157725.465488] usb usb3-port1: unable to enumerate USB device


Apr 29 15:22:20 ubuntu1404 kernel: [158668.754673] usb 3-1: new high-speed USB device number 12 using xhci_hcd
Apr 29 15:22:20 ubuntu1404 kernel: [158668.885855] usb 3-1: New USB device found, idVendor=05c6, idProduct=9008
Apr 29 15:22:20 ubuntu1404 kernel: [158668.885862] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Apr 29 15:22:20 ubuntu1404 kernel: [158668.885865] usb 3-1: Product: QHSUSB__BULK
Apr 29 15:22:20 ubuntu1404 kernel: [158668.885868] usb 3-1: Manufacturer: Qualcomm CDMA Technologies MSM
Apr 29 15:22:20 ubuntu1404 kernel: [158668.887133] qcserial 3-1:1.0: Qualcomm USB modem converter detected
Apr 29 15:22:20 ubuntu1404 kernel: [158668.887354] usb 3-1: Qualcomm USB modem converter now attached to ttyUSB0
Apr 29 15:22:20 ubuntu1404 mtp-probe: checking bus 3, device 12: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1"
Apr 29 15:22:20 ubuntu1404 mtp-probe: bus: 3, device: 12 was not an MTP device
Apr 29 15:22:22 ubuntu1404 kernel: [158670.847529] usb 3-1: USB disconnect, device number 12
Apr 29 15:22:22 ubuntu1404 kernel: [158670.847868] qcserial ttyUSB0: Qualcomm USB modem converter now disconnected from ttyUSB0
Apr 29 15:22:22 ubuntu1404 kernel: [158670.847914] qcserial 3-1:1.0: device disconnected

Are the flashing red led codes any information? (5) (12) (35)

Any suggestions appreciated!

  • Can you make it stay in fastboot? And run fastboot devices – Sumeet Deshmukh Apr 29 '17 at 10:14
  • Hi Sumeet. Thank you for your reply. I've not been able to get it to switch on for last two days. The red LED in the lower speaker flashes. Does that mean not enough power to switch on? Could indicate low power? I wondered if that "Qualcomm, Inc. Gobi Wireless Modem (QDL mode)" message, means that it is stuck not charging, and stuck in some kind of firmware mode. – rich May 1 '17 at 2:20
  • Nexus 5X has an internal battery (not user replaceable) but I found online how to take cover off. Is it worth trying to disconnect the battery, to force a reset? – rich May 1 '17 at 2:37
  • maybe that will work, but my knowledge on hardware issues would be based on guesses and nothing else – Sumeet Deshmukh May 1 '17 at 2:39
  • 1
    Good point Sumeet! Yes, if USB data connection is working, it would be surprising if charging was also broken.. although charging circuit may be separate. Usually separate powermangement chip (I am an embedded software developer). Certainly the device is stuck in Broadcomm QDL mode.. – rich May 4 '17 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.