My sister's got cyangonmod 11 to have android kitkat on here sony Xperia P.

At first it was smooth but now she's facing constant crashing of google play services app.

I've seen these links before :
Google Play Services crashing constantly

Cyanogenmod: Google Play Services keeps crashing after update

Google Play Services and Play Store crashing

The error message I get in the logs is different from the first question, I tried to install google play services from apkmirror as suggested by the second answer, I tried to install versions 10.2.98 and 10.5.53, the version needs to be 030 as suggested by apkmirror and I'm sure about this.

Reinstalling google play services from apkmirror and clearing data does solve the problem at first but the next day or so it comes back.

The output of adb logcat *:F is this :

F/libc    (25812): Fatal signal 7 (SIGBUS) at 0x00000000 (code=128), thread 26060 (pool-48-thread-)
F/ActivityManager( 2121): Service ServiceRecord{431644d8 u0 com.google.android.gms/com.google.android.location.reporting.service.ReportingAndroidService} in process ProcessRecord{42556cf025812:com.google.android.gms.persistent/u0a23} not same as in map: null
F/libc    (26063): Fatal signal 7 (SIGBUS) at 0x00000000 (code=128), thread 26135 (pool-45-thread-)
F/ActivityManager( 2121): Service ServiceRecord{43304570 u0 com.google.android.gms/.phenotype.service.PhenotypeService} in process ProcessRecord{4295d810 26063:com.google.android.gms.persistent/u0a23} not same as in map: null
F/ActivityManager( 2121): Service ServiceRecord{431afc48 u0 com.google.android.gms/com.google.android.location.reporting.service.ReportingAndroidService} in process ProcessRecord{4295d81026063:com.google.android.gms.persistent/u0a23} not same as in map: null

I'm sure those are the crashes because that's where I say the crash message.

I don't understand that not same as in map : null thing , could you tell what does it means ? and how do we solve this issue ?

My sister also tried the suggestion in this site : https://forums.oneplus.net/threads/found-a-fix-for-google-play-services-crashing-constantly.312830/ which didn't work.

If you need the full output of adb logcat or maybe adb logcat *:E I'll be happy to add them, the phone is also rooted and TWRP recovery is installed just so you know.

  • Just some raw guesses: "map" might refer to the Google Services Map (kind of a list of available services), which seems not to know about the one that wants to start (null). And: as all that GoogleService stuff usually needs to be a system app, have you installed it as such?
    – Izzy
    Commented Apr 29, 2017 at 10:35
  • @Izzy yes I have it installed as such
    – niceman
    Commented Apr 29, 2017 at 14:21
  • @Izzy I've got to admit though that I had removed it using System apps remover, I recoverd it and cleared google play services data, will report back if that solves the issue :)
    – niceman
    Commented Apr 29, 2017 at 14:24
  • Ah! That could indeed be the culprit. OTOH, I found that kind of installation (just using the .apk from APKMirror) reported unstable more than once. Usually, one flashes the entire GApps zip file. Or uses something better and less privacy-intrusive, like microG :)
    – Izzy
    Commented Apr 29, 2017 at 18:13
  • 1
    @Izzy it did but since the problem sometimes comes back xD I'll still wait before posting an answer
    – niceman
    Commented Apr 30, 2017 at 11:38

1 Answer 1


The problem solved, previously we had used System app remover to remove some system apps we thought we don't need, we removed google maps, as Izzy guessed google play services was looking for it without finding it ending in a constant crash.

When we restored back google maps app , cleared data no more crashes since then and the phone became faster and more responsive too :) .

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .