0

So I made an app a system app using a 3rd party app but I noticed that I could still uninstall it using the stock android's settings(screenshot included). And I am sure that it was installed in the /system/app/ or the priv-app because i checked it using a root explorer.. so this is what I did to test things after it..

First I uninstalled an preinstalled system app(Chrome) using link2sd.. restarted then I downloaded it again and made it a system app then restarted again and I cant uninstall it using the stock settings. Ive been playing with my root explorer looking for clues and still no luck other than the system/vendor/etc/Generic/Launcher/default_workspace/ which has 2 files that both have a list of preinstalled apps but I doubt that they determine what is uninstallable and what isnt I think theyre just files that determines where apps are placed in the launcher defaultly. I also tried installing to system via adb but same result.

This is an app that I turned into system app: https://drive.google.com/file/d/0B6cwi1mZj5KEak5GLVpOZThZT0k/view?usp=drivesdk

What might be the reason they are still able to be uninstalled (using stock settings) despite being in the /system/ ? What could be the possible solution? tnx

  • Welcome to Android Enthusiasts! I'm quite a bit condused by the word "uninstallable". Do you mean "able to uninstall" or "unable to install"? Please clarify so that we can correctly understand what you're saying. – iBug May 1 '17 at 13:03
  • You can replace "uninstallable" with "removable" or "deletable" if you mean "able to uninstall", or replace with "non-installable" if you mean "unable to install". – iBug May 1 '17 at 13:06
  • ah sorry i mean able to uninstall. check the pic. ill edit the wording right away – Dark Fakinaway May 1 '17 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.