0

Whenever I record with the voice recorder app on my Galaxy S5, the "system" sounds turn on— that is, the bloop sound whenever I click on something, the typewriter sounds when I type, the lock-click sound when the phone unlocks, etc. I would rather these sounds stay off permanently, and am tired of having to keep turning them off in settings. How can I get these sounds to stay off?

  • No idea why it happens. To fix that you can try automation using Macrodroid. Create a macro with Trigger: Application launched > your recorder app. Action: volume change > set system sounds to zero. Constraints: blank. This should fix the problem or you may need to set other sounds to zero if it is not a system sound ( like notification sound). Let me know how it goes – beeshyams May 20 '17 at 6:21
  • Are you rooted? – Andy Yan May 20 '17 at 8:27
  • It seems you keep the phone in silent mode. When you start audio recording app app, system automatically changes its mode from silent(or vibrate) to Normal mode. Check your audio Profiles and also turn off Audible touch tones, Audible selection etc in you sound settings. – Iftekhar May 21 '17 at 11:24
1
+50

I reckon this has to do with Samsung Galaxy S5 enhanced audio features typically Wise Voice

According to Samsung:

Wise Voice, a new feature of the Galaxy S5, lets the volume and quality of a voice call remain consistent, no matter how far or near you speak from the phone. When you speak too far away from the phone or the sound is too low, Wise Voice detects it and turns the volume up; when you speak too close to the phone, it automatically lowers the volume.

I believe this somewhat have effects on system sounds, as volume is auto-controlled by the system to suit the specific environment.

Additionally the Samsung Galaxy S5 has 2 microphones. As explained from this article: https://forum.xda-developers.com/galaxy-s5/help/microphone-problem-t2807110

The secondary microphone is used for active (ambient) noise cancellation. This can be weighted as well when recording audio. Normal mode uses both mics omnidirectionally. Interview mode uses the secondary mic only in a directional beam pattern. And conversational mode takes directional top and bottom audio.

Your issue could be caused by a number of things from poor audio quality, poorly chosen presets or an obstructed microphone triggering volume to up.

As a possible fix try adjusting the Samsung "wise voice" feature that adds microphone gain to compensate audio recorded from a distant place or tweak the notifications or sound mode settings or perhaps automation to auto-off sounds when recording (e.g using Tasker):

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.