0

I'm using LineageOS14.1 (Android 7.1.2) on a Moto G 3rd gen

I'm using a 64GB sd and my phone technically doesn't support it, it worked fine until I put more stuff on it and then it started to randomly unmount without any warning. So I tried formatting it to ext4 to escape from the lack of official support for exFAT.

The problem is that the SD mounts and i can read from it, however when i try to write or delete any file in It from an app (Solid Explorer and all other apps, even the build in file manager) it fails.

The sd is correctly mounted ($ df -l: /mnt/media_rw/c91[...]19 58G 14G 42G 25% /storage/c91[...]19) and if i try creating or deleting a file in It using adb everything works.

I tried giving the apps permissions to use the sd via the system file explorer, but nothing changes

0

I simplified my way to apps see my ext4 formatted [1] on internal something apps will see folder usb1 and may read it (I have to check the write) .

[1]

mkdir /data/media/0/usb1
su -mm
mount -t ext4 /dev/block/sda1 /data/media/0/usb1/
mount -t ext4 /dev/block/sda1 /storage/emulated/0/usb1/

Full answer here : https://android.stackexchange.com/a/204616/119381

-1

I solved the problem by formatting the SD to FAT32 using gparted as suggested by @acejavelin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.