0

I have a new phone with Android 7 Nougat. After cleaning up the old phone and copying all data from the external SD card to my laptop, I inserted the card into the new phone. It reported an error, and I had to format the card. I checked security settings, and set the phone to encrypt the card.

Using Android File Transfer (Mac only) I copied data back to the card. Using Total Commander or Asus Filemanager or any app I cannot open the external card, and I cannot open any files.

Asus Filemanager sees the card as 08AF-6412, but it has no files. Still it reports that 10GB is used of this 32GB card. If I copy a file to it, it says there is not enough space.

I've formatted the card twice, one time formatting it on my laptop to another filesystem to force the phone to format it again. That didn't help obviously. At some point I saw the option to move pictures and movies to the external card, so I did. The files disappeared. When opening the card on the laptop, the files were there, so it worked kind of.

When I open the settings menu and go to the storage settings, then open the advanced settings, I can see the card, its folders and files. I see that files I wanted to copy are created but no data is copied, so 0 bytes.

Anyway, I've found out that you can use the external SD card as internal memory with an ADB format option. So I've installed ADB on my laptop, enabled USB debugging and authorized the device. Then I followed the instructions, and still it doesn't work.

Questions

  • How can I get external storage to work?
  • Encryption is required!
  • If the external card works as internal memory - that's even better!
0

Today a new update appeared in the phone, and another after that. It seems to work normally now. All apps can read and write to the external SD card.

Glad I waited, because I was considering returning it to Sony to get this fixed.

NB: The second update worked without unlocking the phone by the way. I don't like that! That happened on my previous phone as well.

See Reboot encrypted phone without having to enter password and PIN after crash

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.