I tried to install an app that requested com.google.android.maps.jar.

It gave me INSTALL_FAILED_MISSING_SHARED_LIBRARY and after i runned adb install, logcat showed:

Package se.norstedts.svenskastora requires unavailable shared library com.google.android.maps; failing!.

  1. So I copied com.google.android.maps.jar to system/framework.
  2. Installed Google maps v5.12.0.apk from the device.
  3. I tried to install the app again. Got the same error INSTALL_FAILED_MISSING_SHARED_LIBRARY because of the missing com.google.android.maps
  4. Modified /etc/permisions/platform.xml. I appended at the end of the xml file in the "list of all the libraries available for application code to link against." :

    <library name="com.google.android.maps" file="/system/framework/com.google.android.maps.jar" />

  5. restarted device and discovered that i lost internet conectivity!!

I am still not able to install the first app, and didn't regain internet conectivity after i restored platform.xml to it's original form.

What should I do now? It seems to be a permision problem. Wifi connects with no problems. The apps cannot acces internet.

1 Answer 1


Judging from your actions, I am guessing you have root access and possibly a custom recovery.

First, a word of advice:

DO NOT modify the system framework directly especially permissions/platform.xml. This along with a few other files is responsible for defining what android permissions are, giving the permissions for the core part of the system and the mappings involved with it and the SDK. If you somehow mess up the files, then you could seriously lose functionality and as you noticed, permissions. If you modify other parts of the framework, you could cause system instability, boot loops or it just might fail to boot Android altogether.

Additionally, dropping the jar file into the framework directory doesn't work. This is because its actually installed in system/lib or system/bin (have to check android source. Might have this confused). Next, this jar file is usually installed with Google Apps package (or gapps for short) and the updater-script takes care of all that so if you still want to manually install the jar file, I suggest you look at the updater-script for the location of install.

Now, what is the quickest way to fix this and install the jar file?

  1. reinstall whatever ROM you have - you dont have to wipe the data as only the system was modified. If you have a stock ROM, factory reset wont help. This is because a factory reset wipes the data and cache. It doesn't wipe the system partition that you changed and so the problem will still remain when you reboot.
  2. Flash the latest version of gapps to your phone using recovery. This will reinstall all the Google Apps as well as the corresponding libraries needed to extend their functionality. It will also help your other app work.

You must log in to answer this question.