6

I seem to have run into a bit of a challenge on one of our Android/Samsung devices...

On the device, regardless of what's open, when the battery reaches 25% on discharge, the below screen pops up and covers the entire screen, with MUCH difficulty to get rid of. I've tried to trace it to a certain app, but was unsuccessful in doing so.

Android Popup

Can someone perhaps help with some advice on this, on how to get rid of it?

  • I just got this out of the blue as well, I had to soft reset to get rid of the popup. I can't trace it back to any setting. – Jonathan May 14 '17 at 9:02
6

This is caused by the Peel Remote app. I deleted this app and it stopped.

| improve this answer | |
  • I trust you, but we'll see... My phone is fully charged atm – MADodds May 13 '17 at 16:10
  • 1
    Can confirm that this works. My popup is no more! – MADodds May 14 '17 at 3:38
  • Confirmed again, S5. The popup is no longer a problem. Can't believe Peel shows system-like notifications. It is also against the developer policies, no app can show system-like notifications. – user174673 Jun 26 '17 at 19:55
  • I started thinking it was an actual system popup. It cannot be dismissed and often pops up every 2%. It is draining my battery telling me to save battery power :/ This has been reproduced on 2 samsung devices (S5 and S6 Edge), peel was the cause both times – user174673 Jun 26 '17 at 20:07
  • I did visited the Settings => Device => Sounds and notifications => App Notifications => Peel Remote Over there, I unchecked the Block. It now does not shows the notifications as shown in the image above. Hence it resolved issue on my phone by keeping the application intact. [No need to uninstall/disable the app] – Nisarg Shah Jul 20 '17 at 6:35
2

This looks to be a default setting popup which shows when your battery level reaches to a preset value of 25%. You can change these in Settings->Battery->BatterySaver option where you can either set the level to show the popup at 15% or 10% or you can turn it off by setting the turn on automatically option to NEVER.

| improve this answer | |
1

My only fix is to plug my phone in... It instantly goes away at that point. Though I'd rather it not happen in the first place. It's very intrusive.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.