0

Whenever i try to upgrade the firmware of my galaxy mini gt-s5570 via samsung kies.....first KIES starts to download the firmware...but the phone doesn't show "downloading" on screen first...but every time (8-9 times that i've tried) when the download reaches around 69%-70%.....the upgrade process halts and says"PC cannot recognize the mobile phone" then the phone gets into download mode and shows "Downloading" on the screen! and i have to reboot my phone! What do i do now? any help??

1
  1. Disconnect your phone.
  2. Reinstall the drivers.
  3. Toggle USB Debug mode, reboot your phone and connect it.

If that doesn't work, try putting your phone into Download Mode manually.

  • Yes i tried putting my phone into downlaod mode manually...but it didnt help either....my kies cannot connect to the phone while it is in download mode....it says "connecting..." all the time! is there anything more i can do?? – Saujanya Acharya Dec 28 '11 at 8:23
  • @SaujanyaAcharya You could try backing up your SD storage and then formatting it, Kies has/had a bug where it failed if you had files with long extensions. You could also try Kies Mini if it's available for your device. – Matthew Read Dec 28 '11 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.