About a month ago, the Moto G (3rd Gen) of my wife was not able to recognize the Transcend Premium 400x 32GB SD card (which was formatted as adoptable storage) anymore. On this card were very important pictures and movies for us (of our newborn baby). As of a certain Android version, the adoptable storage is also encrypted, and reading it on a PC or other phones is not possible without the encryption key. Since the phone was also not rooted, it was also not possible to get the encryption key from the /data/...something directory... (see https://nelenkov.blogspot.ch/2015/06/decrypting-android-m-adopted-storage.html). So I almost gave up hope.

I bought the exact same type of SD card, also 32GB, only about a year later. Hoping that I would be able to make an exact clone of the card and I would be able to start some experiments with it without the risk of destroying something on the original card and losing all the data. When I mounted the original card under Linux, it shows two partitions 17MB and about 31GB. Cloning the card with some Linux command-line tools didn't give me the same result.

Is there any other way to fix this issue?


2 Answers 2


This worked for me:

  • Removed the SD card from the phone
  • Plugged the SD card into a MicroSD to MicroUSB adapter
  • Plugged the MicroUSB adapter into the MicroUSB plug on the phone
  • Run ES File Explorer and in my case the SD Card was named '0'. I was able to access the DCIM folder and upload all my photos and videos

NOTE: ES File Explorer Ver was used. When I upgraded it to the latest version so I could upload to Google Drive, it no longer could recognize the files, so I had to downgrade back to and use Dropbox.

  • I have the same problem (as my wife had), my card got corrupted. In order to prevent me from buying a bigger SD-card I tried the ES File Explorer solution. This doesn't work since the card is encrypted by Android and it is not shown up. I tried the solution as @user231138 suggested. So I had to buy a bigger card and bitwise copy the stuff and it worked again! Sep 2, 2017 at 18:13

Taken from the Emiel Kosse's original revision with copyedit.

The next thing I tried was cloning it using HDD Raw Copy, first write the entire card to an image on my hard drive. When I copied the data to my new 32GB card, I noticed that the new card did not have the same capacity as the image file (image was 32.22GB, new card shows capacity of 31.11GB) so that trick doesn't work.

Luckily I also happen to have a 64GB SD card (same type) which should have enough space for this test. So using HDD Raw Copy, I wrote the image to this card. Checked under Linux if I see the same partition as with the original card and this happens to be (of course it also shows about 32GB of free space not partitioned).

So, I thought, let's see if the Moto shows the same error with my new card in the phone and that I made an image on which I can start to try to hack the encryption off (now or in the future). To my surprise, the Moto shows immediately that the transcend 32GB volume is mounted! I went to the gallery of the phone and it shows our pictures and movies again!

So, in short, when this happens, buy a larger volume SD card (to make sure that there are enough data-block available). Use HDD Raw Copy to make a bit-wise clone/image of the original card. Write the image to your new card and check if it can be read by your phone.

Never do the following or your data will be lost:

  • Format the card
  • Set your phone back to factory default (destroys your encryption key)
  • Make the phone to forget/unmount the storage location (also destroys encryption key)
  • upgrade to a newer version of Android (or any other major system update).

(of course, make sure to make backups or cloud syncs to prevent this situation at all)

I hope this can help someone out there who might end up in the same situation.

Not the answer you're looking for? Browse other questions tagged .