0

I'm trying to root HTC Desire 500 Dual Sim. I've been following along this video tutorial: https://www.youtube.com/watch?v=yWLK5XhsVAE

I've unlocked the bootloader and installed CWM Recovery without any issues. When I go into recovery, select "Install zip" and install SuperSU zip, the installation process finishes just fine, it doesn't show any errors, but after I reboot there are no new apps installed and I don't have root access (tested with Root Checker app).

I've tried multiple version of SuperSU (0.96, 0.98, 2.79, etc.), but none of them worked. Also, I can't mount /system while in CWM, not sure what it means.

What could possible cause this? Is there anything I can do?

2

It seems like HTC Desire 500 has a "system write protection", so you may need to flash a custom (modified) kernel to prevent the system from protecting itself from modification.

Check this post on XDA forum.

  • I've followed the instructions, but nothing seem to have changed. Could it be because of "S-ON" thing? Also, I can't mount /system via CWM, maybe that's the reason I can't install anything. Could a custom pre-rooted ROM help in my case or only a different kernel can solve it? – Victor Marchuk May 15 '17 at 7:36
  • A custom ROM already includes a kernel that's compatible with root. – iBug May 15 '17 at 8:30
  • I've installed James ROM via CWM, and once again no root, no new apps, no changes whatsoever. Even my data wasn't removed in the process. I really feel like the problem is that CWM isn't able to access /system folder for some reason – Victor Marchuk May 15 '17 at 8:35
  • Any ideas on something else I could try? – Victor Marchuk May 15 '17 at 15:54
-2

Try this:

  1. Download SuperSU application from Google Play;
  2. Download latest recovery flashable zip from here: http://www.supersu.com/download ;
  3. Flash recovery flashable zip via your custom recovery.

EDIT: Also I suppose you to check root availability after this procedure by actually downloading application that needs root access to work. Root Checker can not display root rights even if they available because of SuperSU switching from system to systemless which means that root gets installed in data partition istead of system one and, because of this change it can be impossible for Root Checker to detect until it'll be updated to detect it properly.

  • It doesn't seem to have changed anything. When I run SuperSU after that, it shows an error about missing bin files. If I type su into a terminal, it shows su: not found. It seems like CWM isn't able to install binary files for some reason. Any idea on what else I can do? – Victor Marchuk May 14 '17 at 11:08
  • I suppose you ask this question in this thread: forum.xda-developers.com/showthread.php?t=2597314 as your problem seems to be device-specific. – Vyacheslav V. May 14 '17 at 12:03
  • @AndyYan Correct me if I'm wrong, but isn't systemless root installed by patching the boot.img? – Death Mask Salesman May 14 '17 at 14:05
  • It can be, I can't correct you on this topic as I'm not fluent enough in it. I just supposed that Root Checker app wasn't able to detect superuser installed because of SuperSU switching to systemless with one of latest updates and described as I imagine it for myself. – Vyacheslav V. May 14 '17 at 16:59
  • 1
    Makes no sense that Root Checker doesn't check systemless root. It has been quite some time since systemless root was invented, so no reason for RC not to support it. – iBug May 15 '17 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.