I just received my Amazon Kindle Fire and since I am not located within the USA I can't use most of services provided Amazon. So I think the best thing for me would be to install a vanilla (custom) Android ROM.

How can I install vanilla Android on the Kindle Fire?

1 Answer 1


The most stable option at this point is to use CyanogenMod. You can get it onto your Fire by doing the following:

Root and Custom Recovery

On Windows, you can use the Kindle Fire Utility to root the Kindle Fire and install Team Win's recovery (TWRP). It's extremely straightforward, and should even set up the Google drivers for you. The whole process is done via a command-line numeric menu.

On non-Windows OSes (of if you just prefer it) you can manually root with BurritoRoot. It's also fairly painless. You'll then need to set up adb on your OS, and install TWRP, which can be done by following this guide on RootzWiki. The gist of it is that you need to reboot into fastboot and then flash the recovery image, which should be:

user@linux ~ $ adb shell
$ su
# idme bootmode 4002
# reboot
user@linux ~ $ fastboot -i 0x1949 boot path-to-twrp.img
user@linux ~ $ fastboot oem idme bootmode 4000  <-- After auto-reboot
user@linux ~ $ fastboot reboot

Or something along those lines.

Flashing CyanogenMod

This works just like any other recovery system, really. Just grab CyanogenMod and put it onto your /sdcard partition. Reboot into TWRP by powering off the device, then pressing/holding the power button at the FIREFIREFIRE bootloader (installed with the TWRP image), and use TWRP to select and flash the CM zip.

Cyanongenmod for Kindle Fire

  • @Flow I know that you accepted the answer, but can you confirm that you actually did this and it worked with no problems?
    – Mawg
    Commented Dec 2, 2015 at 11:09
  • Do you know if the Kindle Fire will support Android 5? Or even 6? And if the method is still the same?
    – Mawg
    Commented Dec 2, 2015 at 11:10
  • 1
    @Mawg The first gen Kindle Fire? I would doubt it, but I have no idea. Commented Dec 2, 2015 at 14:53
  • The latest generation.
    – Mawg
    Commented Dec 3, 2015 at 8:56
  • 1
    @Mawg These instructions probably won't have any relevance on the latest generation; they were written for the first gen version. You'll most likely need to find new instructions for that device (or post a new question). Commented Dec 3, 2015 at 14:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .