2

My phone is a Huawei Ascend Mate7. I get the following notification whenever I turn on my 4G connection:

Data lost

You have lost data connectivity because you left your home network with data roaming turned off

The problem is my SIM card is from the same country I live in now. This problem somehow remained since I moved from my old SIM card, and now I can't seem to get rid of it. I also see an "R" next to the connection indicator.

How to solve this?

1
  • Should have nothing to do with your device. Are you logged-in to your providers network? Maybe it has no coverage where you are, and because of that your device logged in to some other network. You could try to show available operators, and possibly chose to manually select your provider's network (instead of letting the device chose), if only to see whether it fixes the issue. You should find that in Settings › Mobile Data (or similar).
    – Izzy
    May 16 '17 at 9:34
0

I solved this by going into Settings, SIM and network, and selecting SIM 1 (the phone carrier SIM in my case Giffgaff). This showed me another setting for mobile data which was switched off. Once I switched it on, it found a nearby 4G source.

0

Go into Settings, SIM and network, and selecting SIM 1 or SIM 2 according to the slot used by the problematic SIM.

This shows another page for mobile data or "roaming". Roaming is for sure switched off, which is the problem here. Turn roaming on. Now, the phone will remain silent and quiet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.