4

Last night, my phone (Samsung Galaxy S6) updated from Android 6.something to Android 7.0. Since I use my phone for typing both Dutch and English very often, occasionally even within the same conversation, and I am a very sloppy typist, I used to have predictive text and autocomplete/autocorrect on for both Dutch and English. This was working (mostly) fine: it would seemingly just find the closest approximation to what I had typed in either language.

Since the update, I have to explicitly choose a language by sliding the space bar. This is annoying, since it adds at least one action, and furthermore I keep forgetting, having to delete whatever I have written so far before switching languages and retyping it.

Would it be possible to go back to the situation I had before the update?

I have been using the default keyboard, with which I am otherwise very satisfied.

  • 1
    are you using the stock keyboard or google keyboard? There's an option for multilingual prediction that should be enabled in google keyboard settings. Check if you can find something similar if you're using samsung keyboard – Albin K C May 19 '17 at 4:49
3

The same problem happened to me a few days ago, which was resolved thusly :

  • Go to the keyboard settings : Settings>Language and Input>Virtual Keyboard>Samsung Keyboard
  • Check that your languages are selected in 'Languages in types'
  • Make sure that the "Predictive" option is activated.
  • Make sure that the "Auto replacement" option is activated.
  • Restart the app on which the keyboard was used so new settings are applied

That last point is the one that made it work again for me so I can type ugly things like "Holà yeah le clavier marche again" without having to slide the space bar.

This was suggested to me by the French Samsung support which answered (within a day !) the following :

En effet, pour apporter une solution à votre demande, nous vous proposons d'effectuer les manipulations suivantes dans les "Paramètres" du clavier :

  • ajouter le français et l'anglais dans "Langues et types" ;
  • cocher le "Texte intuitif" ;
  • cocher "Vérif. orthographe auto." ;
  • Fermer et redémarrer l'application sur laquelle vous avez fait le reparamétrage du clavier.
  • This had a weird effect for me: while the predictive test was no longer exclusively Dutch, it did very strongly prefer Dutch words, almost always replacing misspelled words with Dutch even if they were much closer to English, and occasionally replacing even correctly spelled (common) words from English to Dutch. Since this is for now the closest to a solution to my actual question, I will upvote (edit: not enough reputation for that) and accept, though. (At this point I am so used to SwiftKey that switching back offers no real advantages, and SwitfKey does what I want out of the box.) – Mees de Vries Jun 21 '17 at 13:06
1
+100

I have found a app that may fix your issue: SwiftKey by Microsoft. It is a beautiful keyboard that supports bilingual autocorrect. Get it here

1

You can try this if you are using stock Samsung keyboard:

Go to Settings >> Language and Input >> Virtual Keyboard >> Samsung Keyboard >> then add your other language (you may need to download).

or

Settings > General Management > Language and Input > Virtual Keyboard > Samsung Keyboard > Add your other language.

(may depend on android version)


Alternatively, I'm the sure latest version of Google keyboard (Gboard) has multiple keyboard support for predictive text.

Credits : How to change keyboard back to simultaneous language after Samsung 7 Edge update

(I am still using android 6, had not thought of this as issue, but credits to the forum for a heads up, hope it works for you)

  • Your recommendation sends me to the situation I am already in. My keyboard does recognize both languages, but not simultaneously, which is what I am looking for. – Mees de Vries May 22 '17 at 8:21
  • Thats a bit strange, since this workaround proved to be successful for many – xavier_fakerat May 22 '17 at 17:24
  • I don't think so. I think there are users with different issues in that thread. Some people want to have both languages available with a simple toggle, but not simultaneously, while the users who want both languages simultaneously (like me) continue to be frustrated, since that was an option before (the default option even, I'm pretty sure). – Mees de Vries May 23 '17 at 7:29
  • Ok I get it, I am still trying to look for a solution and will inform you of any updates but I guess this is a Samsung back end issue, and your OS may need to be patched by Samsung to fix this issue. – xavier_fakerat May 23 '17 at 10:18
  • 1
    Having looked some more, I feel like Samsung just decided that they don't want the option anymore. I guess I will try out SwiftKey. – Mees de Vries May 23 '17 at 13:03
0

Android 7 is installed on my smart phone but I do not see the part virtual reality! If you have the same problem, follow this way: setting -> general management -> language and input -> on-screen keyboard -> Samsung keyboard -> language and types -> management input language here choose the second language which you had added in the languages of your keyboard in (setting -> general management -> language and input -> language).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.