1

I have been trying to unlock the bootloader on my Moto G 3rd Gen, so I can install TWRP Custom recovery and flash a new system image, as my phone will not boot up at all (including recovery mode).

I have tried to follow the steps on the Motorola website, but when I get to the command: fastboot oem unlock (i have the code, not showing it here) it says:

(bootloader) Check 'Allow OEM Unlock' in Developer Options.

However, as the phone cannot boot up, I can't check allow OEM unlock in the developer options.

anybody know how to get round this so i can install TWRP?

0

First download the corresponding firmware for your devices here.

Then follow (at your own risk) this updated guide.


I had the same problem with a Xperia M4 Aqua, and I couldn't override the 'OEM Allow Unlock' since phone wouldn't boot up. I tried to perform the follwing in order to override that:

fastboot erase cache
fastboot erase userdata

It didn't work for me, but you can try on your phone, maybe you get lucky.

Since I was on Sony Xperia, I managed to flash a stock firmware using Sony Flashtool.

  • 1
    Your link is for the incorrect device... the OP stated he had a Moto G 3rd Gen (also called Moto G 2015), which uses different files and firmware, I would encourage needsomehelphere1 to NOT follow this guide. The Moto G 2015 can be restored to operating condition with a locked bootloader if we have access to the same or a newer version (downgrades are not permitted with a locked bootloader) and there are tutorials on XDA in the correct areas to perform this. Unfortunately, the versions of stock firmware that have been leaked are somewhat dated so it would depend on the release on the device. – acejavelin Nov 6 '17 at 19:56
  • @acejavelin my bad, I agree with you. I couldn't find a nice guide on Moto G 3rd Gen forum. This one that I recommended is very detailed and would help as long as the correct firmware is used. I'm editing my answer right now to clarify that. – Johnny Nov 7 '17 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.