0

On my Android phone, I can connect to websites and browse them fine. Also, if I turn my mobile Hotspot on, I can connect a desktop/laptop to it, FTP into the phone itself etc.

However, if I try to connect to any website from my laptop over the Portable Hotspot connection, this fails. traceroute to 8.8.8.8 shows about 10 hops, with about 53 msec trip time, ending at 209.85.241.35 or 216.239.56.19 - but doesn't go all the way there.

What could the problem be? And how can I circumvent it?

Notes:

  • Ping from my computer to my phone (192.168.43.1) works.
  • Connections fail even if I use numeric addresses, so it doesn't look like a DNS issue.
  • I have a Redmi 3S phone, with Android version 6.0.1 (MMB29M) - with no customizations, just official updates.
  • I'm in the US and using Simple mobile.

Additional ex-post-facto information:

When I flew back to the Netherlands and switched to my local cellular provider (T-Mobile Netherlands), everything was working fine and I could connect to websites from the same laptop - without any configuration changes whatsoever, both with numeric addresses and domain names. So it must be some issue with the cellular provider (or compatibility on the phone side, or the laptop side, with what it offers).

  • Likely problem with DNS, what DNS are you using? – xavier_fakerat May 21 '17 at 21:34
  • If you ping 192.168.43.1 are you receiving packets? There is some options I'm thinking of right now: Try changing DNS settings to Open DNS or Level 2/3, check if you can access web, maybe the APN settings are somewhat blocking access or there is a firewall in between. Alternatively isn''t there an installed app using a tunnel interface? – xavier_fakerat May 21 '17 at 21:43
  • @xavier_fakerat : 1. I set my DNS to 8.8.8.8 instead of the local address of whatever DNS cacher Ubuntu zesty has on by default. But this shouldn't matter since connecting to sites using their numeric address doesn't work either. I'm not sure what you mean by "" opening level 2/3" 2. Ping to 192.168.43.1 works. – einpoklum - reinstate Monica May 21 '17 at 21:47
1

This may be an issue with your carrier's APN (DUN and IPv4 protocols).

As a workaround, try changing the APN type to DUN:

  1. On your phone, go to Settings >> More >> Cellular networks >> Access point names
  2. Tap the entry for your carrier.
  3. Scroll down to APN Type and add ,dun at the end (so the it should say default,supl,mms,dun).
  4. Ensure the APN Protocol and APN roaming protocol are set to IPV4
  5. Save your settings.
  6. Restart the mobile hotspot.
  7. Disconnect and re-connect to the hotspot from your laptop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.