1

I'm trying to root my phone, and I was told that because I own a Galaxy S6, I need to unlock my bootloader. My carrier is AT&T, which makes it apparently even more difficult. I've tried things such as fastboot, which will get stuck telling me waiting for device input. I'll look that up, and it turns out I need to install PdaNet if that happens. Of course, PdaNet is blocked by AT&T and there's no way to install it.

I've found at least a dozen articles and the like on the matter, and none of them have worked. If anyone's got some advice, or even just a flat-out "it can't be done", I'd greatly appreciate that. I'd also like to know if unlocking the bootloader is necessary, and if it isn't, I'd love to know what I've been doing wrong, and what my next steps should be or what guides are good and up-to-date. Thank you all in advance!

  • 1
    At this moment, "flat-out 'it can't be done'". Once again, a lesson not to buy phones from AT&T and Verizon again. P.S. normally Samsung devices have no fastboot. – Andy Yan May 24 '17 at 11:21
  • @AndyYan is there some other way to proceed with the rooting process that doesn't involve unlocking the bootloader? – WubbaLubbaDubbDubb May 24 '17 at 11:24
  • From what's in XDA, nope. Modern phones pretty much deny rooting methods other than installing a recovery and a SU package. – Andy Yan May 24 '17 at 11:32
  • How would I go about doing that? – WubbaLubbaDubbDubb May 24 '17 at 11:37
  • @AndyYan Also, this link from XDA seems to suggest otherwise: forum.xda-developers.com/att-galaxy-s6/development/… – WubbaLubbaDubbDubb May 24 '17 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.