1

I am unable to view the PIDs or process names associated with network activity on my android device. I was wondering if there is another way to go about doing that, besides netstat? Or if anyone might know what netstat: '234/nvram_agent_binder' > 21 bytes means?

Below I have a copy/paste of the help message of my android device's version of netstat, followed by my attempt to run netstat with the -p flag. This is being performed over adb with root access:

1|root@DEVICE:/proc/234 # netstat -h
netstat -h
usage: netstat [-pWrxwutneal]

Display networking information.

-r  Display routing table.
-a  Display all sockets (Default: Connected).
-l  Display listening server sockets.
-t  Display TCP sockets.
-u  Display UDP sockets.
-w  Display Raw sockets.
-x  Display Unix sockets.
-e  Display other/more information.
-n  Don't resolve names.
-W  Wide Display.
-p  Display PID/Program name for sockets.

netstat: Unknown option h

It doesn't like when I use -p:

1|root@DEVICE:/proc/234 # netstat -tulpn
netstat -tulpn
netstat: '234/nvram_agent_binder' > 21 bytes
1|root@DEVICE:/proc/234 #
1|root@DEVICE:/proc/234 # netstat -p
netstat -p
netstat: '234/nvram_agent_binder' > 21 bytes

Other options appear to work fine:

1|root@DEVICE:/proc/234 # netstat -t
netstat -t
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 ::ffff:192.168.1.x:33380 xxxxxxx.net:xxx ESTABLISHED
root@DEVICE:/proc/234 #

Any help would be greatly appreciated!

1 Answer 1

1

To anyone who runs into this: I solved the issue by getting the relevant toybox binary from here https://github.com/landley/toybox and transferring it to my device via adb.

Then using: ./toybox netstat -p

That worked well

1
  • Strangely toybox didn't fix the issue either. I suspect it's probably xposed interfering though. Mar 11, 2018 at 1:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .