So I acquired a Nexus 6 with a completely dead screen. (Dead as in I cannot see anything)

The phone powers on (and off) and is detected by my computer.

I want to be able to see the phone's display on my computer. I believe the process will be straight forward if I mange to get ADB enabled

The phone is presumably locked (I do know the unlock pattern) and USB debugging is disabled.
adb devices gives no output

When I boot into recovery mode, fastboot devices recognizes my device.

The phone is probably unrooted and has a locked bootloader. I do not need to preserve any data.

If I manage to get ADB working, I known of tools that will allow me to view my phone screen, which is my end goal.

I looked at Broken screen while debug mode was disabled. How can I re-enable adb? but when I tried booting CWM recovery rom, I got the message "FAILED (remote failure)" because the bootloader is locked? Similar problem with Android toolkit.

Anyone know of a way to enable ADB through fastboot when USB debugging is not enabled

Thanks in advance

EDIT: I followed this guide to not avail

$sudo fastboot flash recovery twrp-3.1.1-0-shamu.img 
(bootloader) slot-count: not found
(bootloader) slot-suffixes: not found
(bootloader) slot-suffixes: not found
(bootloader) has-slot:recovery: not found
target reported max download size of 536870912 bytes
sending 'recovery' (11757 KB)...
OKAY [  0.535s]
writing 'recovery'...
OKAY [  0.189s]
finished. total time: 0.724s
$ sudo fastboot reboot
(bootloader) slot-count: not found
(bootloader) slot-suffixes: not found
(bootloader) slot-suffixes: not found
  • Welcome to Android Enthusiasts! While waiting for answers, it's definitely worth having a look at our broken-screen tag-wiki, which has some first-aid and links to related questions (yes, you're not the first one with that issue ;) Good luck!
    – Izzy
    Commented May 29, 2017 at 9:37
  • @Izzy Thank you for the relevant information. I tried following the instructions, but I believe I am doing something wrong. My device is never detected by ADB. I have found recovery images through Google and tried booting them with fastboot to no avail. Any advice? Commented May 31, 2017 at 20:58
  • I've never been in that situation (luckily), but I'd try with TWRP first – as there I'm sure ADB is built-in and active per default.
    – Izzy
    Commented Jun 1, 2017 at 6:39
  • @Izzy I followed this guide: twrp.me/devices/motorolanexus6.html, but when the device reboots, adb still won't detect it. Any other advice Commented Jun 5, 2017 at 1:20
  • I forgot to boot the recovery image; my bad; adb detects the device, but says I don't have permissions; EDIT restarted with sudo and it worked Commented Jun 5, 2017 at 1:36

1 Answer 1


I followed this guide

  1. I went into fastboot mode by holding down the power button (force restart) and the volume down key (recovery mode)
  2. I downloaded a twrop image from: https://dl.twrp.me/shamu/
  3. fastboot flash recovery twrp.img
  4. fastboot reboot (while holding the volume down key see note)
  5. Then I booted the recovery image
  6. adb with root permissions detected my device. If you get a permission denied error try killing adb and running with sudo

*Note many devices will replace your custom recovery automatically during first boot. To prevent this, use Google to find the proper key combo to enter recovery. After typing fastboot reboot, hold the key combo and boot to TWRP. Once TWRP is booted, TWRP will patch the stock ROM to prevent the stock ROM from replacing TWRP. If you don't follow this step, you will have to repeat the install.

  • Note that if you don't want to modify your stock recovery, you can also boot TWRP "from image" when needed: fastboot boot twrp.img. Good job!
    – Izzy
    Commented Jun 5, 2017 at 10:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .