I am trying to install Ubuntu Touch on Vodafone Smart Mini 7(Android 6.0), I followed the instruction from Ubuntu Official site and when I hit sudo fastboot oem unlock ,press UP volume button, I get this error : FAILED (remote: Unlock operation is not allowed)

Besides this, I don't have "OEM Unlock" button in Developer Tools, neither on my main phone Huawei P8 Lite(Android 6.0), both phones bought from Vodafone store, so they are blocked in Vodafone.

A friend's Samsung J5, blocked in Orange has the "OEM Unlock" option and that's pissing me off.

As I seen from several forums, some opeartors lets you unlock the OEM, some doesn't, in my case Vodafone doesn't. Is there a way to enable this option and continue Ubuntu Touch installing?


In some devices you can enable OEM unlocking even with the option being disabled in the Developer options menu. Ensure ADB Debugging is enabled on the device and try this command

sudo -i
adb enable oem unlocking
adb reboot bootloader

Then, once the bootloader is loaded use fastboot to attempt an oem unlock. Note that this still may not work as many devices require a code or unlock token from the manufacturer to actually unlock the bootloader and I can find no information of a successful bootloader unlock for this specific device.

Also be aware that Ubuntu Touch has been discontinued and your device does not seem to be supported anyway, so all this may be for nothing. There also does not appear to be any custom ROM's available for your device.

| improve this answer | |
  • uhm, it won't take enable command, everytime when i write adb enable, terminal thinks I only write adb and shows me the commands ; won't work with adb shell either – sticsk Jun 1 '17 at 16:23
  • @sticsk So it is disabled by the manufacturer on a deeper level than just removing it from the developer menu. There is no other way to enable OEM unlocking. Most likely the manufacturer has setup this phone so that the bootloader cannot be unlocked. – acejavelin Jun 1 '17 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.