0

I have installed an app fusing its apk. After installation, I clicked on 'Done'. Then, I checked app on app drawer and Settings->Apps, it was not found there. I am running Nova launcher, in Lineage Os 14.1,Rooted, Xiaomi Redmi 1s. Earlier, in settings it showed 47 apps installed, now it shows 48 apps installed(including hidden app).

  1. I have checked for app in /data/app, app not found.
  2. Installed Quickshortcutmaker to create app shortcut, but app not found.
  3. Tried to hide in Nova settings, app not found.
  4. Tried to reinstall that apk, it overwrites app like an update.

I need to uninstall this app.

The app is PixBar (installed apk), In file name like this com_dunrite_pixbar-10011002.apk.apk. And while opening through es (for install), it showed package as net.upper.master.support.texas.stem.threw, which is found as malware(google). I try some apps like this(install from apk), but, this have no option to uninstall, which I have never experienced before.

  • So does pm list packages show its package ID? – Andy Yan Jun 2 '17 at 3:09
  • how to perform this? I am not experienced in adb, terminal installations. Now, I installed terminal, applied root permissions. – Rahul Gopi Jun 2 '17 at 3:29
  • Just execute this from a rooted shell (terminal), it will give you a long list of installed package IDs. Search for the anomaly inside. Also, if you still have the app's APK in your hand, you should know its package ID as well, so you know what to look for. The ID is in AndroidManifest.xml - search for keyword "manifest" in the file, and the ID is right after the first entry, in "bla.bla.bla" format. – Andy Yan Jun 2 '17 at 3:33
  • What will happen if you click on launch instead of done? Some apps may install in stealth mode. Case for spying apps. – esQmo_ Jun 2 '17 at 3:58
  • I cannot launch, because for the first time I clicked on DONE, after that I installed again, but now launch option is hidden, only Done is available. – Rahul Gopi Jun 2 '17 at 4:01
1

Seems like a spying apps which can install in stealth mode and never being detected.

Try with ADB commands to check if it appears in the list of installed apps and eventually delete it.

  1. Download Minimal ADB and fastboot . Unzip and run it. (Windows machines)
  2. On the phone, enable USB debugging in Settings > Developer Options > USB Debugging. If the Developer Options is not present: Go to Settings > About then hit 7 times on Build number then go back to Settings.
  3. Depending on your phone, you'll need drivers for your device to be detected (Windows).
  4. Connect the phone to the computer. On the terminal window, type adb devices [press enter] this checks if the phone is detected. Output : xxxxxxx devices
  5. Type adb shell [press enter]
  6. Type pm list packages -f [press enter]. A long list of apps with their packages name will output, just check if your app is listed.
  7. Then to delete the app, type cd /system/app [press enter] or cd /system/priv-app [press enter] depending on the app location and then type rm app_name.apk [press enter] (app names are case sensitive).

Note: An alternative for Minimal ADB and fastboot which is available for Linux, Mac and Windows as well, can be found in the answers on Is there a minimal installation of ADB?.

Since you are using Nova Launcher, I remember you can hide apps. Check if you didn't do so inadvertently.

  • Go to Nova's Settings menu, by either long-pressing on the home screen and selecting the “Settings” icon in the bottom right, or heading into the app drawer and tapping the “Nova Settings” icon.
  • Open the second entry App & widget drawers
  • In the Drawer groups section, select the **Hide apps* option.
  • Then check if the app appears there and eventually uncheck the check mark.
  • 1
    When on Windows (which is the only OS supported by the linked installer), you might need specific drivers installed before you can succeed in step 3 ;) When not on windows, check with Is there a minimal installation of ADB? (and find the appropriate archive e.g. on my site). – Izzy Jun 2 '17 at 5:54
  • Thanks! Maybe you also want to include the link from my previous comment – for people who are not on Windows? The page you've linked states it only works for <list-of-Windows-versions>. – Izzy Jun 2 '17 at 6:05
  • Done editing. Windows users which I am, are lazy :) – esQmo_ Jun 2 '17 at 6:12
  • Yeah. And they are mixing things up. Like now: Your original link is Windows only. The one I gave (and you included now) is available for Windows, Mac and Linux – nothing to do with .NET and stuff. ;) I've fixed it up, hope it's OK with you :) – Izzy Jun 2 '17 at 6:16
  • 1
    Oops! My bad, I clearly confused Minimal ADB and fastboot with Debloater which requires .Net Framework as I was about to suggest OP this alternative also. Need to switch to Linux :D – esQmo_ Jun 2 '17 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.