-1

I was developping an Android app on my stock 7.1.2 nexus 5X and next thing you know, the bottom buttons are not working anymore and I can't open the notification tray. I can't access developer options because "they are not enabled on this user", and user settings are not working (when I click on it nothing happens).

I saw online that it was related to some corruption somewhere, and that the phone was in "setup wizard" mode. The easy solution is to open the wizard back or reset the configuration using adb, but I'm facing a security exception because the SetupWizardActivity is not exported... I also tried the Nova Launcher trick but same security issue there. I finally wiped the cache partition, with no success.

Here is the command I tried and its output :

adb shell am start -n com.google.android.setupwizard/.SetupWizardTestActivity

Starting: Intent { cmp=com.google.android.setupwizard/.SetupWizardTestActivity }
java.lang.SecurityException: Permission Denial: starting Intent { flg=0x10000000 cmp=com.google.android.setupwizard/.SetupWizardTestActivity } from null (pid=9864, uid=2000) not exported from uid 10026
    at android.os.Parcel.readException(Parcel.java:1684)
    at android.os.Parcel.readException(Parcel.java:1637)
    at android.app.ActivityManagerProxy.startActivityAsUser(ActivityManagerNative.java:3137)
    at com.android.commands.am.Am.runStart(Am.java:643)
    at com.android.commands.am.Am.onRun(Am.java:394)
    at com.android.internal.os.BaseCommand.run(BaseCommand.java:51)
    at com.android.commands.am.Am.main(Am.java:124)
    at com.android.internal.os.RuntimeInit.nativeFinishInit(Native Method)
    at com.android.internal.os.RuntimeInit.main(RuntimeInit.java:262)

Do any of you have a solution ? I would really like to not factory reset the device :(

  • I don't own a Nexus device, but there should be a feature called Home or Home screen in Settings, see to what is set as default. Normally it's the default launcher that is set as default. – esQmo_ Jun 2 '17 at 19:53
  • It's set to Evie, my usual launcher – natinusala Jun 2 '17 at 20:07
  • Okay. But what happed exactly? Did your app cause this? What do you mean by "I was as developing"? – esQmo_ Jun 2 '17 at 20:28
  • I was on Android studio developing and app, and when I hit run I noticed that the phone was acting weird : the home and multitask buttons are not working, the notification tray cannot be opened, I don't have any notification, the status bar is stucked at default icons, I can't enable wifi or Bluetooth... The phone is back like it's not been setup, out of nowhere – natinusala Jun 2 '17 at 20:59
0

I ended up factory resetting the phone. It looks like there is no solution to resolve this issue if it has not been rooted beforehand, or at least the bootloader unlocked. You can't even unlock the bootloader since developer options are not accessible when the phone is bugging like this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.