0

Recently I noticed that whenever I try to login to a captive portal Wi-Fi page, all of the browsers that I'm using crash. This happens before the page even finishes loading and consenquently I am unable to log in to the Wi-Fi service.

I have tried using different browsers (Stock Android browser, Google Chrome, Dolphin browser and Opera Mini). The following error shows:

Unfortunately "browser" has stopped 

for each of the mentioned browsers or sometimes they just close to home screen with no specific error message. I suspect it may be due to a conflicting certificate signature or problems with certificate because Chrome shows NET::ERR_CERT_AUTHORITY_INVALID with HTS error but I have no substantive evidence for this, since it used to work fine before.

Also I have noticed that on the other device running Android 7.0 it reports a problem with the certificate:

There is a problem with the security certificate for this site

What could be the cause of the problem and are there any workarounds to fix this?

Edit: I've included the screenshot

⅝

  • A Captive Portal Login never requires a certificate. I suppose the Wi-Fi is badly configured so that all browsers crash. Have you tried another Wi-Fi with CPL or an alternative device? – iBug Jun 3 '17 at 8:10
  • Thanks, On desktop when using Chrome, it usually displays certificate error, so I use IE to login to WifFi service and so far its the only browser that access captive portal with no issues. For Android all browsers crash, from time to time Chrone eventually loads but it first presents a certificate error on the webpage, that is why I thought it may be certificate issue causing this – xavier_fakerat Jun 3 '17 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.