1

I locked my phone during a false "it's been stolen" panic using Google's device manager.

I chose a nontrivial password. I thought I was safe since I cut-and-pasted the password after first typing it in a text editor.

Now either something is wrong or my fingers are incapable of duplicating this password on the (now found) device itself.

Is there a way to cut-and-paste the password from a computer, rather than on the device itself? The device is in developer mode and is not rooted.

Update

Luckily I had the "Hacker's keyboard" as an option. The default Gboard keyboard does not give any feedback, but this hacker's keyboard flashes the last key pressed. Now I know with certainty that I've typed the password exactly as I had cut-and-pasted it. Hence entering the password on a computer may not help either. I wish they'd have added an "Unlock your phone" feature along with "Lock your phone" on Google's device manager page.

Update 2:

As a reference I'd like to mention here that entering a second password using the GDM is rejected. You're stuck with the first password you chose.

Having a GDM as flawed as this is still better than risking that your private information gets in the hands of random strangers, but be prepared to wipe your phone when you recover it. It may be the only option remaining.

  • I've read about this issue quite a few times here (see these search-results: the password set via Google Device Manager doesn't unlock the device in some cases). I have not followed it up, but with some luck one of the answers in the linked result set helps you out of the misery. – Izzy Jun 3 '17 at 10:50
  • Sometimes when you cut & paste an extra "space" can be added, have you tried the passcode with an extra space at the end or leading space? Otherwise, try resetting the lock passcode on Google ADM again and wait about 15 minutes with the device booted up (assuming it has a network connection). – acejavelin Jun 3 '17 at 11:55
  • @Izzy If they don't properly debug the Device Manager lock/unlock procedure for a Nexus device (non-rooted, most recent official update, etc), it makes one wonder how much debugging has gone into the GDM before release. Thanks for the information and pointer. I'm going through them. – Calaf Jun 3 '17 at 20:12
  • @acejavelin I used a text editor with which I'm extremely familiar (Emacs), and so I'd like to think that this is not an option, but then I have few other options than to try blindly. As I mention in the update, the "Hacker's keyboard" at least shows the characters as one is typing them. – Calaf Jun 3 '17 at 20:15
  • @Calaf doesn't make me wonder. How long do we have that "Google backup", and the restore still doesn't work reliably? Somehow sounds similar: "backup works, restore not" vs. "locking works, unlocking not"… – Izzy Jun 3 '17 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.