1

I noticed on a device that the play store app didn't work until I inserted a SIM card: is this just a bug or does the Google play app requires a SIM card being present?

Background: I've installed LineageOS + OpenGApps Nano on a Nexus 5 device (without a SIM card). Almost everything worked as expected, including the google account creation.

What didn't work was the Google Play store app, though. When going to the 'my apps' sections there was just an endless checking for updates/connecting animation. Installing apps wasn't possible. Clearing the cache/app data etc. didn't make a difference.

What helped was this: inserting a SIM card! After that and clearing the app data/cache again the Google Play store app worked as expected.

  • No SIM or service is required. How long did you wait, possibly was just Google Play or its services updating? – acejavelin Jun 3 '17 at 14:00
  • @acejavelin, I waited ~ 45 minutes, also tried it several times with reboot and cache-clearing in between. Downloads via other apps (e.g. fdroid) finished with normal speeds. – maxschlepzig Jun 3 '17 at 14:38
  • Odd. A SIM is not required, we have lots of devices in our test bench, from Gingerbread to Nougat, includes lots of Nexus 5's, never had to have a SIM in any of them to use Google Play. – acejavelin Jun 3 '17 at 14:41
  • Ok, if you post this as answer I'll accept it. – maxschlepzig Jun 3 '17 at 14:55
3

No, a SIM is not required to access to Google Play on any device.

  • 4
    If it were, it couldn't work on SIM-less tablets :) – Izzy Jun 3 '17 at 15:25
  • 1
    @Izzy, well, technically, the play store app could only require a SIM card if the device also has a sim card slot. Sure, acejavelin's answer contradicts this possibility. – maxschlepzig Jun 4 '17 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.