I noticed on a device that the Play Store app didn't work until I inserted a SIM card: is this just a bug or does the Google Play Store app requires a SIM card being present?

Background: I've installed LineageOS + OpenGApps Nano on a Nexus 5 device (without a SIM card). Almost everything worked as expected, including the Google account creation.

What didn't work was the Google Play Store app, though. When going to the 'My apps' sections, there was just an endless checking for updates/connecting animation. Installing apps wasn't possible. Clearing the cache/app data etc. didn't make a difference.

What helped was this: inserting a SIM card! After that and clearing the app data/cache again, the Google Play Store app worked as expected.

  • No SIM or service is required. How long did you wait, possibly was just Google Play or its services updating?
    – acejavelin
    Commented Jun 3, 2017 at 14:00
  • @acejavelin, I waited ~ 45 minutes, also tried it several times with reboot and cache-clearing in between. Downloads via other apps (e.g. fdroid) finished with normal speeds. Commented Jun 3, 2017 at 14:38
  • 1
    Odd. A SIM is not required, we have lots of devices in our test bench, from Gingerbread to Nougat, includes lots of Nexus 5's, never had to have a SIM in any of them to use Google Play.
    – acejavelin
    Commented Jun 3, 2017 at 14:41
  • I have the same issue. I read somewhere that in order to solve play store connection issues, you need to enable automatic time and time zone. This takes its information from the cellular network, which in turn needs a SIM card.
    – Paljas
    Commented Sep 23, 2022 at 16:32

4 Answers 4


No, a SIM is not required to access to Google Play on any device.

  • 4
    If it were, it couldn't work on SIM-less tablets :)
    – Izzy
    Commented Jun 3, 2017 at 15:25
  • 1
    @Izzy, well, technically, the play store app could only require a SIM card if the device also has a sim card slot. Sure, acejavelin's answer contradicts this possibility. Commented Jun 4, 2017 at 20:04

A SIM card is required to download from the Google Play store; I just verified it through my Galaxy Note 20.

  • Could you also explain what would happen if no SIM card was inserted? I'm using Pixel 3a without SIM and I have no problem installing and updating apps from Play Store.
    – Andrew T.
    Commented Apr 18, 2021 at 13:45

I was trying to use one of those Calypso phones AT&T sent out for my child to do Zoom. I had to download it from the website directly instead of the Play Store. I was afraid if I used the SIM card they gave me, it would activate the phone instead of the new upgrade I got after receiving the Calypso.

I'm signed into my Google account, but it tries to update or download apps, but then quits and points me to a help page that said to clear the cache - no mention of requiring SIM card, yet it seems to. I got into the developer options by tapping the build a bunch of times, but it still has no setting I can find to bypass the SIM card.

  • Regarding "no mention of requiring Sim card, yet it seems to.", could you provide the exact message and/or provide a screenshot of it? This might help in collecting the info on which situation the user needs a SIM card to access Play Store.
    – Andrew T.
    Commented Jan 19, 2022 at 8:20

I had to insert a SIM and then sign into the Google Play store first. Then after that, I can remove the SIM and still be able to download through WiFi. Tested on LG V10, Galaxy S23, Revvl 6 pro, OnePlus N20.

  • The first part does answer the question, you need a sim to sign into google play, then after that you can remove and still install apps through wifi. The second part is related to not being able to install apps through google play with sim removed, once signed in.
    – Robert Lee
    Commented Jun 23 at 18:06
  • 1
    Hi, I removed the second part because it's tangential to the question, and I also think it's still incomplete: have you tried downloading through wire while the SIM card is in place? Otherwise, it's unrelated to the SIM card. (I noticed that you also have posted the question regarding that issue)
    – Andrew T.
    Commented Jun 25 at 6:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .