0

I have a Motorola X 2013 Dev edition unlocked (XT1053) that I'm trying to flash the stock firmware onto after using Cyanogenmod12. However, the process is failing. Following Motorola's instructions...

After downloading the image for your device:

Make sure you have a Moto Pure Edition or a Developer Edition device. Make sure you download the corresponding recovery image from the above portal. To flash, put the phone in fastboot mode: 1. Power OFF your device 2. Then Power ON + Volume Down Alternatively, you can reboot into fastboot mode if you have adb...adb reboot bootloader. Next flash the images using fastboot: $ fastboot flash partition gpt.bin $ fastboot flash motoboot motoboot.img $ fastboot reboot-bootloader $ fastboot flash logo logo.bin $ fastboot flash boot boot.img $ fastboot flash recovery recovery.img $ fastboot flash system system.img $ fastboot flash modem NON-HLOS.bin $ fastboot erase modemst1 $ fastboot erase modemst2 $ fastboot flash fsg fsg.mbn $ fastboot reboot You also have the option to erase all the data on your device with $ fastboot erase userdata $ fastboot erase cache

I apologize for the horrible formatting there...

When I try to flash gpt.bin, the following error appears on my phone

downgraded security version
update gpt_main version failed
preflash validation failed for GPT

Now I've looked into this quite a bit and found that it is caused by motorola's own security protections. The only thing I can find to get around it is waiting for the new security patches. However, those threads I find are pre dropped support. Cyanogenmod is probably responsible for this since it is still getting security patches. Therefore, there never will be an updated stock to flash.

How do I get around this issue? I have a nandroid backup of the phone pre-cyanogen, but I'd rather just flash a clean stock than use the backup if possible.

  • Which model number? XT something ? – esQmo_ Jun 3 '17 at 16:13
  • @esQmo_ It's an XT1053 – Ethan Z Jun 3 '17 at 16:22
  • I remember had similar issue flashing the XT1052 model, solved with mfastboot commands instead of fastboot commands – esQmo_ Jun 3 '17 at 16:27
  • You need a newer ROM image... Preflash Validation Error indicates the image you are trying to flash is older than what's installed currently and you need a newer image. In all honesty, you can usually just skip gpt.bin and bootloader.img or motoboot.img and your good. – acejavelin Jun 3 '17 at 16:46
0

I've been in a similar situation with the XT1052 model, I don't know if the script below will work for you.

Boot in fastboot, either manually or through ADB. Then type:

mfastboot oem fb_mode_set
mfastboot flash partition gpt.bin
mfastboot flash motoboot motoboot.img
mfastboot flash logo logo.bin
mfastboot flash boot boot.img
mfastboot flash recovery recovery.img
mfastboot flash system system.img
mfastboot flash modem NON-HLOS.bin
mfastboot erase modemst1
mfastboot erase modemst2
mfastboot flash fsg fsg.mbn
mfastboot erase cache
mfastboot erase userdata
mfastboot erase customize
mfastboot erase clogo
mfastboot oem config carrier vzw
mfastboot oem fb_mode_clear
  • I just noticed a fastboot executable for darwin is specifically inside the rom folder. I'll give that a shot for mfastboot – Ethan Z Jun 3 '17 at 16:36
  • Just update us . – esQmo_ Jun 3 '17 at 16:37
  • Same exact error using the provided fastboot – Ethan Z Jun 3 '17 at 16:39
  • This only happens with the gpt partition? – esQmo_ Jun 3 '17 at 16:40
  • I haven't tried any of the others. I don't want to brick the phone as it's my daily use one. – Ethan Z Jun 3 '17 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.