1

I recently got myself an S8+ running Android 7.0.

One of the most (arguably) shallow reasons for getting this nice new phone was for the always on display it offered, where it would show the clock, your battery and the date.

It also promised to show me my notifications, and for about a week or two, that's exactly what it did.

It would show everything, from missed calls, to applications from the store, to weather updates. It showed every notification I had from any application without doubt or question. And I loved it.

Recently however it's just stopped. It doesn't show anything except the time, the battery and the date. No notifications. No missed calls. No new texts. No nothing.

I have my always on display checked as "on", run a default theme that came with the phone (although I have tried others). I have it set to show "Home button and clock or information" (which is the default) and have "Show always" on too.

I'm not that much of a power-user and I haven't tampered with the phone's services or anything, so I don't really know what else I can tell you about the problem. If I'm leaving out some key information please tell me.

How can I go about bringing my notifications back to the always on display?

The only thing that is not an option is resetting the phone.

  • Make sure in Settings - Notifications - Advanced in upper-right - "Always on Display" is set to "Allowed". Back out of here back to Settings, then Lock screen and security - Other security settings - Notification access - make sure "Always On Display" it turned On. – DukeSilversJazz Jun 5 '17 at 18:45
  • Sorry mate, both of those settings were already in the state you described :( – ViRALiC Jun 6 '17 at 4:02
  • I have noticed that my S8+ seems to get stuck. Most recently my fingerprint stopped working as if I didn't have the setting turned on. I did a full power off and back on and it started working again. I wonder if there are problems with the system trying to do too much and it looses settings. – CaptainBli Jun 12 '17 at 22:20
1
+50

There are possible reasons why these notifications no longer show:

  1. Type of Always on Display (AOD) mode you are using (Clock/Calender)

    • It has been noted that if you're using the calendar AOD mode then you won't see any notifications, just the clock, calendar, and battery %.

I could not get any notifications when using the calender AOD, but I do get messages and missed calls when using just the clock options in AOD. Nothing on emails in either, and I'm using the stock email app for an exchange work account. I could not get any notifications when using the calender AOD, but I do get messages and missed calls when using just the clock options in AOD.


  1. Email client incompatibility

    • Sometimes there's some incompatibity or bug in the stock email application causing this. Check your email clients and if possible try switching to Gmail client. It somehow worked for one user.

I switched my email accounts from the Samsung email app to the Gmail app (both email accounts are non-Gmail types). Now my notifications are working fine. I'll assume there is some problem with the Samsung email app regarding notifications going to the Always On Screen.


  1. New changes introduced in AOD updates

    • It could be that new updates in the AOD features have brought some changes with it, for example the most notable change was the requirement of screen lock option.

You must use one of the screen lock options for notifications icons to appear when phone is in AOD mode. Before the update this was not necessary.

I picked the Swipe in the lock screen options and my notifications came back. It was working before that last update

Possible solutions

In addition to the above you may additionally try the following to resolve the AOD issue:

  1. Clearing app data

    • Do a clear data for Always On Display. Go your device’s Settings >> Applications >> Application Manager >> Always On Display > Storage > Clear data
  2. Fine tuning miscellaneous notifications

    • Make sure notifications are allowed for Messages. In the device’s Settings >> Notifications, make sure the switch next to Messages is turned on.
  3. Switch to another Always On Display layout


Other workarounds

  • Install alternative Always On AMOLED – BETA from Google Playstore

References

  • Clearing the app data worked for me! Thank you! – ViRALiC Jun 15 '17 at 7:31
  • Thats great ! Anytime :) – xavier_fakerat Jun 15 '17 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.