I want to connect Kindle Fire with Eclipse to develop apps but I don't see any entry like "Development" in "Settings". What's wrong with it? If it doesn't exist on KF, is there any way to do that? When I open Manage on Windows XP, a yellow exclamation mark appears on Kindle. Is its driver missing?


It is always enabled on the Kindle Fire. You simply need to add the Fire's device ID to your android_usb.ini file so that the Google ADB drivers will find it. You can do this from the command line very easily with:

echo 0x1949 >> "%USERPROFILE%\.android\adb_usb.ini

Then restart adb

adb kill-server
adb start-server

And you should be good to go.

If it still won't recognize it then you may need to go into the "Manage" menu and uninstall the Fire, then unplug it and plug it in again (I don't remember if that step was necessary).

  • where is android_usb.ini? – emeraldhieu Dec 30 '11 at 18:32
  • @Emerald214: On XP is should be C:\Documents and Settings\<username>\.android\android_usb.ini. On Vista/7 it should be C:\Users\<username>\.android\android_usb.ini. – eldarerathis Dec 30 '11 at 18:38
  • I tried this and followed your advice. freerepairguide.com/kindle-fire-enable-usb-debugging.html but the KF doesn't appear on device list (step14). – emeraldhieu Dec 30 '11 at 19:53
  • @Emerald214: So the driver and everything installed properly like in the guide? In your Windows device manager, do you see a "ADB Interface" (or similar) device? – eldarerathis Dec 30 '11 at 19:58
  • Yes, I saw it, ADB Interface. I tried to unplug and plug USB cable then restart adb but nothing changes. It shows this error in console "Adb connection Error:An existing connection was forcibly closed by the remote host" – emeraldhieu Dec 30 '11 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.