0

I have the Xiaomi Redmi Note 4 and this phone is NOT rooted yet. However, I am not sure if this is a hardware-specific issue or not. The phone is a day old, so I don't know if it should have been working before.

When I insert an audio jack (headphones, tried two pairs), no audio is played through them, but instead, continues playing through the main speakers.

Xiaomi support lines are reportedly bad, so I won't try, especially since I can't find their support email/ticket site in the first place.

Following is the specs:

Device Android ID/Codename: Nikel
Android: 6.0.1 MMB29M - MIUI8
Patch Level: 2017-04-01
MIUI Version: MIUI Global 8.2 Stable (8.2.5.0 MCFMIDL)
CPU: Octa-Core Max 2.00GHz
RAM: 3.00 GB
Internal: 32GB
Kernel: 3.18.24-perf-g798c6bf

Is this a hardware issue, or a software issue? If it's software, what should I do to fix it, and is this a known issue?

1
  • I rebooted and it started working, but I'll leave this question unanswered because I don't know what the problem was. Jun 7, 2017 at 18:04

1 Answer 1

0

Seeing that it works (see question's comment), this answer is somewhat unnecessary, but for the future in a Q&A fashion, I'll put in my 2 cents.

There are a couple of things to know here. Glitches happen, and stuff breaks. We obviously prefer the first. Here's a couple of steps to isolate the cause.

  1. Quoting the IT crowd "Have you tried turning it off and on again?". Seems dumb, but it works. If this fixes it, it's a software issue. (Hopefully one you won't be seeing again)
  2. Quoting the IT crowd again, "Is it plugged in?". Check that the connections inside the port are clean and nothing is stuck in there. Don't go sticking anything wet in there, but maybe a very very mildly damp q-tip could do the trick.
  3. If neither of these do anything, try a factory reset. If that doesn't work, it's hardware damage.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .