1

I nearly get nuts because I cannot root my ZTE Blade V6 (europe version).

In the past I have rooted several android devices. Actually it was quite the same procedure everytime:

1. Install platform-tools (adb and fastboot)
2. Make device appear in "adb -devices"
3. Make device appear in "fastboot devices"
4. Flash any recovery via fastboot (I tend to prefer CWM)
5. Copy Custom-ROM (usually a *.zip for the OS and one for gapps) to internal or external space 
6. Start phone into recovery and install the zip and afterwards the gapps
7. Done

However this seems to fail on the ZTE Blade V6 this time:

If I go to the stock recovery, it is all in chinese (or some other letters I can not read). So I flashed a CWM recovery.img to the phone, from https://forum.xda-developers.com/android/software-hacking/twrp-recovery-3-0-2-zte-blade-v6-t3362252. The flashing seems to work (However it says: target didn't report max-download-size) But it does not boot into it. It just does not do anything after flashing the recovery. No Recovery, no fastboot. Only thing that works after that is normal start. Directly sending adb reboot recovery after flashing makes a simple restart of the device into stock ROM.

I tried different recovery images but the output is usually the same.

Somewhere I found a command that does directly boot the image and not only flash it:

fastboot boot recovery.img

All the images I tried report FAILED (remote: bad boot image header) when directly booted this way.

Can someone tell me what's wrong and/or help me flash my droid?

  • 1
    What about unlocking boot loader? Pre requisite for most devices? ( I don't know about your device though ) – beeshyams Jun 9 '17 at 16:17
  • 1
    Your steps are not wrong, but the prerequisites might not be there: unlockable bootloader (what @beeshyams mentioned), a recovery made for the specific device (note that ZTE has a lot of "Blade" devices that are all different - don't cross-flash them), a custom ROM made specific (same as above). The error about recovery you get sounds like you flashed a recovery from another device onto it. Mind sharing links to what you found and flashed? – Andy Yan Jun 10 '17 at 8:09
0

First of all, make sure that you got the proper "recovery.img" for your device. Invalid header is not a good message.

Then,if you are able to communicate with an Android phone via adb, you can boot it into recovery mode by command "adb reboot recovery".

What I suggest for your situation is(I assume you don't need fastboot oem unlock):

  1. Make sure your PC can see your device by the command: "adb devices".
  2. Boot into fastboot mode by the command: "adb reboot bootloader".
  3. Flash recovery image to recovery partition: "fastboot flash recovery recovery.img".
  4. Exit fastboot mode: "fastboot reboot". (Some bootloaders may support fastboot boot recovery.img, I am writing for generic.)
  5. After exiting fastboot mode, wait for Android to boot, then check if your PC communicates with your device: "adb devices".
  6. Reboot into recovery mode: "adb reboot recovery".
  7. Now, the bootloader is expected to load CWM.

In case you need "fastboot oem unlock"(you will see a warning like "partition flashing is not allowed" at 3rd step above, because of verified boot feature.); under Settings->Development Settings, turn on OEM unlock. Then, run below commands:

  • adb reboot bootloader
  • fastboot oem unlock
-1

Install Blade Checker then see but sounds like you have chinese version not european might solve the language problem.

  • Blade Checker tells me unknown device. Bootloader unlock by "fastboot oem unlock" gives me "..." as output and freezes there. Device still there in fastboot devices – Johnny Jun 10 '17 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.