0

I have a Nexus 6 (just factory reset). When I connect it to my computer through USB, it charges, but nothing else. My computer doesn't recognize any new device being plugged in, and my phone does not pop up with the dialog asking what I want to do (Charge, MTP, PTP, etc.), nor do I get a notification asking this, even when pulling down from the notification drawer. I am running Android 6.0. I have another Nexus 6, and it works fine. When I plug the first Nexus 6 into any computer, I have the same issue, while the second device works fine in any computer. I have tried Windows and Mac computers.

  • In developer options check select USB configuration is not set to Charge only – beeshyams Jun 11 '17 at 13:22
  • I did, I actually did another factory reset and haven't enabled developer options yet just in case that was part of the problem – vcapra1 Jun 11 '17 at 13:24
  • But it was set to MTP before – vcapra1 Jun 11 '17 at 13:25
  • I see. Possibly changing USB cable and checking may help – beeshyams Jun 11 '17 at 13:59
  • I have tried several usb cables, and no difference – vcapra1 Jun 11 '17 at 14:55
0

You should try some of the following:

  1. Make sure your phone is not encrypted. (Settings>Personal>Security>Encrypt Phone).
  2. Try enabling USB debugging in dev settings and use adb devices and see if it is listed (you will obviously need adb).
  3. Keep trying USB cables!
  4. Try using something like ASUS File Manager to wirelessly transfer the files.
  5. If they are photos you are trying to transfer, consider using Google Photos (accessible at drive.google.com)
  • 1. It is encrypted, but so is the other phone (the one that works). However, I am trying pretty much everything now, so how do I decrypt it? 2. I have adb, and it is not listed 3. I will :P 4. I will look into this 5. It is not just photos, but also files and I want to flash an Android N image at some point – vcapra1 Jun 11 '17 at 22:46
  • Nevermind apparently you can't decrypt without a factory reset. Even though I did a factory reset it and it's still encrypted. Hmm – vcapra1 Jun 11 '17 at 22:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.