0

I'm currently running AfWall+ on LineageOS (Android 7.1.2) and seem to have a problem with this app. When I'm on WiFi it doesn't stop anything it's supposed to (works just fine on mobile). Can someone please advice what cold be the problem?

1

I came across your question because I had the same problem, and I just figured it out (although it might be a different cause in your case).

Details of my case (to see if it applies):
I'm also on 7.1.2 (LineageOS 14.1), and I'm using a VPN with AFWall+ v2.9.8. AFWall+ is supposed to only allow connections through the VPN. It's actually been working fine for a while, but it suddenly started allowing connections through my WiFi even when the VPN was off (it still worked properly on mobile data).

I eventually came to the conclusion that this was caused by the fact that my ISP provider started switching to IPv6, and it seems that AFWall+ doesn't support IPv6 by default (by that, I mean it doesn't apply the rules to IPv6 traffic). This is, of course, a wild guess, because I couldn't find any manual for it that explains the details of the slightly cryptic/confusing settings (e.g., not sure what the "Only Control IPv6 Chains" option means and why it is mutually exclusive with the "IPv6 support option).

Solution:
Having said all that, the solution that worked for me was to go to Preferences > Rules/Connectivity and under "IPv6 Chains", check the option for IPv6 support ("Enable support for IPv6").

When I applied the firewall rules after doing this, it applied twice as many rules as it was before I enabled IPv6 support. This is what led me to believe that previously, it was only applying my rules to IPv4 traffic, while now, it's applying my rules to IPv4 and IPv6 traffic (hence, twice as many rules).

Of course, even if I'm unclear on the AFWall+ settings, the main reason I believe this is the cause/solution is that everything works as expected now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.