3

I have an Acer Iconia B1-A71 which I bought about a year ago, if I remember right. It has Microsoft Word for Android pre-installed. In my naivety I assumed it was a free no-strings-attached app.

Today I was taking a train trip, 2 hours each way, and I thought I'd try using it to work on a fairly large Word document. I sent it to myself via email. Clicking on the .docx attachment started the Word app. It went though an initialization process, but I am very sure that it did not warn me that by using the app I would have to sign up for a Microsoft account and provide permission for Microsoft to access my contacts.

I spent about three hours working on the document during the trip.

When I got home I tried to "share" it by sending it to myself again. What I got was the original unmodified document. Then I tried to "Save as" on the device, and the app crashed or went into a loop, spinning the circular arrow and saying "Working on it". After 4-5 minutes I killed the app.

Now when I start the Word app it demands that I sign up for a free account, and share my contacts with Microsoft. This I refuse to do on principle.

Where I come from this kind of thing is called "bait and switch".

So my question is, is there any way I can find and recover the edited .docx file using File Manager or something (I have tried to find the edited document but can only find the original one), or do I accept that Microsoft has cheated me out of three hours of my time?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.