Hi enthusiastic community! I would need your help and advice!

The device:

  • Samsung Galaxy Tab S2 (SM-T819)
  • bought with Android 6 second hand --> last week updated to Android 7
  • NOT rooted, original firmware, official update (did not mess around with it at all ...)
  • I am using it without SD-card or SIM

The problem:

Stucks in boot loop first shows Galaxy Tab S2 logo and then S-A-M-S-U-N-G appears in big letters blinking) stays there forever and heat up a little on the back.

Steps already tried and did not work out:

  • press powerOn button 10s, 1 min, 2 min ... --> no reaction
  • press volUp + volDown + powerOn --> reboots put stuck later at the logo
  • press volUp + powerOn + home --> does not enter recovery mode
  • press volDown + powerOn + home, in this very order --> enters downloading mode and asks to downloading a custom OS (volUp) or cancel (volDown)
  • if I press cancel reboots and stuck at the logo again
  • if volUp then gets into Odin downloading mode and shows the following information:

    CURRENT BINARY: Samsung Official
    SYSTEM STATUS: Official
    RP SWREV: S1, T1, H1, R1, A2, P1
    download mode !!
    [Arrow down]
    Downloading ...
    Do not turn off target 

I guess it is waiting to download from USB.

  • tried this steps with and without charging cable connected to my laptop --> does not make a difference!
  • Eventually it ran out of battery and shut down! Tried the same steps after it's shutdown (power cable connected) but situation did not change!
  • I cannot mount the tablet on my Ubuntu Lenovo Thinkpad --> if I do lsusb the tablet is not listed ...
  • after the battery ran out I tried this: when Samsung Galaxy S2 logo appears, release the Power key and immediately hold the volume down key --> it is rebooting and showing the battery symbol (0% charged) over and over again.


  • What should I do else?
  • Should I flash firmware? --> I run the laptop with Ubuntu 17
  • Should I dismantle it and disconnect the battery (worked on my Lenovo ...)?
  • Do I have to root it?

What do I want:

I want the tablet to work again, would prefer not to root it, do not care about data loss ...

Other observations:

  • I could not start it this morning after installing a new app (via Google Play) yesterday evening.
  • Two days ago I could not charge the tablet with the adapter on a power plug, I needed to charge it via the laptop.
  • It is alive and charges normally on the laptop (if I press shortly the powerOn button then the battery symbol appears)
  • Does NOT charge with the charger plugged into a power plug, only on the laptop.

Thanks a lot for your help and patience to read all that!



I followed esQmo_'s solution in detail but I could not establish a connection between the computer and the tablet. In the end Samsung support fixed it and the tablet is running perfectly again. However, I think that the solution given by esQmo_ is still the right thing to do in this case, but please note that for some reason (maybe my lack of experience or knowledge) it did not work out for me. Thanks!

  • Seems like you bricked it. You simply need to flash it using Odin (Windows) or Heimdall (Mac OS). I can help you flashing with Odin. i don't have a linux machine.
    – esQmo_
    Commented Jun 15, 2017 at 16:36
  • @esQmo_: Thanks a lot for your help! It seems I have to find somebody with a Mac or Windows! Could you point me to a good tutorial which help me to flash it or could you post a recipe as an answer? Commented Jun 16, 2017 at 8:30

5 Answers 5


Seems like a softbrick state. You should try flashing a new firmware. The steps below are for Windows:

  • Download the firmware from here (Registration required)
  • Download Odin flasher from here
  • Download Samsung Kies and install it. Needed for drivers.


  • Uninstall Kies right after it has installed and drivers set up, this is to avoid conflicts with Odin while flashing devices (See below answer (@Babaks D's answer) for more)

  • Unzip the firmware, unzip Odin then run the executable file.

  • Power off the device then boot in download mode (Volume down + power button) then connect it via USB cable. Windows should install drivers.
  • Now on Odin, you should see ID COM turns blue meaning that the device is detected.
  • Click on AP button, then browse where the firmware folder is. Select the file. Wait a moment.
  • Now click on Start and wait till the end. You should see PASS on the screen.
  • Thanks for your help! Unfortunately it did not work for me. I could not fix my tablet by myself, but the Samsung technicians did. I could not establish a connection between the computer and the tablet maybe due to my lack of experience or knowledge. However, I think that your answer is still the right thing to do in that situation, there for I accepted it as solution! Commented Jul 13, 2017 at 9:06
  • You probably didn't install drivers to establish the connection between the phone and the computer or the USB cable was defective . I'm glad you had the issue fixed though.
    – esQmo_
    Commented Jul 13, 2017 at 11:22

My solution in the end was to send it in to Samsung and it got fixed by them. That is not a practical solution for everyone especially if your support for your device is already expired. However, with this post I just wanted to state that it was possible to fix it. The tablet has been working perfectly since then and the boot loop might have been connected to the update to Android 7.0.


I tried the solution @esQmo_ suggested. It went all good until the very last stage where Odin failed on installing the firmware. After doing some more research, I figured that you should not be running Kies as you want to interact with Odin.

Kies installs the drivers for you, but if you want to run Odin and download the new firmware on the device, Kies interferes and tries to communicate with the same device on the same port, resulting in having the COM BUS busy and thus Odin won't be able to download the firmware.

So if you want to follow the steps @esQmo_ laid in, make sure that you have closed Kies before downloading the firmware on the device.

  • Hello, you meant Kies, not 'Keis', or? could you please edit your post? Commented Dec 4, 2017 at 15:14
  • Hello. Yes, just a minor typo. Thank you for pointing that out. Edit applied.
    – Babak D
    Commented Dec 4, 2017 at 15:29
  • Thanks for pointing this out. I fogot to mention that in my answer. The better option would be uninstalling Kies just after it has installed the drivers, so you won't worry anymore about it.
    – esQmo_
    Commented Feb 3, 2018 at 21:28

For me, the following procedure helped (SM-T813):

Prerequisites: ADB, ODIN, TWRP-tar-file for device

  1. Initial State: "stucked" TWRP is running on device
  2. Connect device to PC
  3. Reboot device into download mode (I did it via "adb reboot bootloader")
  4. Start ODIN, flash the latest version of TWRP (I assume its just important to "reflash" TWRP)
  5. After the flash completed, my device returned to normal boot mode

My tablet was on a recovery boot loop and would proceed to install update only up to 25-32%. I tried clearing the cache by pressing the upVol and Power button but I couldn't get to that menu, perhaps because it wouldn't charge at all and I had to keep it plugged in. I did the power button + downVol and home key at the same time to get to the custom OS install screen, I left it sitting there for a good 15 minutes and I think it was able to sustain a charge so when I rebooted it finally completed the update on it's own. Weird but it finally updated after a few days of installing update loops.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .