1

I've been using a voice recorded app on Android called "Parrot" that stores recordings to

SD card\Android\data\com.SearingMedia.Parrot\files\parrot

I know they're here because when I select a recorded file from within the app, and press on details, it says

File location: \data\user\0\com.SearingMedia.Parrot\files\parrot\Jun 09,063342.wav"

However, when I connect my phone to the computer, the folder is empty. The files work, as they can be heard when played from the app, but they just don't appear on the file explorer.

Now, I saw the developers wrote this as an answer to somebody asking the same:

Hi David, Internal recorders are stored in a folder that is in a private sandbox folder which is inaccessible to other apps for security. You will need to share all of your tracks outside of the application. Long press on a row to start the multi-select tool then tap on all of your tracks. We suggest sharing using our SendAnywhere integration.

I don't want to use these wireless methods. Is there any way at all that I could access these files on this protected folder, by merely connecting the phone to a computer?

  • If you want to avoid the sharing option, your device will need to be rooted. Is it? – Matthew Read Jun 16 '17 at 1:27
  • It will if this is a real option. I've rooted phones before, just not this one because so far I haven't had the necessity. – firewater Jun 16 '17 at 2:32
0

You could use another sharing option such as Share to SD. This will save the file locally on your device in a non-sandboxed location, and you will then be able to access it from your computer.

| improve this answer | |
  • I've installed it, but for some reason it won't appear as an option for sharing on Parrot (not along with "Bluetooth", "Drive", "Email", etc). Also, say I've got a file, that I know is in that folder, that won't be displayed by "Parrot" (so I can't share it in any manner, not even with Internet) - do you think there's any chance of recovering it? I'd need to enter the folder, of course. And, thanks much for responding. – firewater Jun 16 '17 at 2:37
0

I also use Parrot for all my recording purposes, so here's the solution:

First, in the settings of Parrot you need to choose External instead of Internal for the memory storage location. Weirdly, Parrot will then store your files in the internal memory in a folder called "Parrot".

After that, when I connect the phone to the PC and I can see "Parrot" folder in the internal memory section, but none of the recordings. So, install an app like "FX Explorer" on the phone, which is pretty much my default file browser. Then browse to the "Parrot", from the menu select Rescan media, and refresh the Windows Explorer on PC, the files will show up. :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.