0

I have a question about connecting an Android phone to a Mac. I expect you'll need to know some specifics about the hardware and OS versions I'm using. So let me start with that.

Macbook: MacBook Pro Retina, Mid 2012, OS: OS-X 10.8.5 (Mtn. Lion)

Old smartphone: HTC Rezound, OS: Android 4.0.3 (Ice Cream Sandwich)
Old cable: Micro-USB connector to USB-A connector

New smartphone: LG V-20, OS: 7.0 (Nougat)
New cable: USB-C connector to USB-A connector

For years I've been able to connect my old Android smartphone (HTC Rezound) and my MacBook through a USB cable and OS-X will mount two filesystems from the smartphone so they appear on the Mac as if they were local filesystems. One filesystem represents the phone's internal memory and the other filesystem represents the MicroSD card in the phone. In a Finder window on the Mac, two new icons appear when I plug the phone in, one for each filesystem. And at a shell prompt, if I 'cd /Volumes', two new subdirectories appear.

I should mention that years ago, when I first connected the two, the HTC asked me if I wanted to use the connection to charge the phone or for data transfer, and I selected data transfer.

I'm now trying to set up my new smartphone which is an LG V-20. When I connect it to the Macbook with a USB-C to USB-A cable, the LG phone displays a number of things I might want to do with the connection, including charging the phone or data transfer, and I select data transfer. But on the Mac, no icons appear in Finder and no subdirectories appear in /Volumes.

So, I'm unable to access the phone's filesystems from my Mac.

Anybody have any ideas?

0

I'm sorry I don't have a solution for you, only a small clue. I have the same issue with my LG V-20 and Windows 10 on a Surface 3. I run diagnostics on Windows 10 and it tells me that the V-20 does not support USB3. Since the only kind of port on the Surface 3 is USB3 I'll need to try another computer. (I'm on vacation and have only the Surface with me so I cant try this out right now.) If your macbook has USB2 ports you might try these or if not, try an older computer if available.

  • Ignore my post above. Here's what worked for me. When you plug your phone into the USB port you should get a notification ON YOUR PHONE (not on your computer) prompting to "Tap to change USB options". Tap it and change setting of "Use USB connection for..." to File transfer or Photo transfer, etc. – user237454 Sep 15 '17 at 20:52
  • I set "Use USB connection for..." to "File Transfer", but I still cannot see any icon in Finder on the Mac that represents a filesystem in the Android. And likewise, I can't see any subdirectory of /Volumes on the Mac that represents a filesystem in the Android. As I said in my first post, I'm running Android 7.0 (Nougat) on the LG and OS-X 10.8.5 (Mtn. Lion) on the Macbook. What versions of Android and OS-X are you running? – MBR Sep 15 '17 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.