Normally I can add a desktop link from Chrome by using "Add to Home screen". However, when I click on a YouTube video, it automatically opens that video in my YouTube app rather than in Chrome. Thus I no longer have an option to add something to my home screen.

Any ideas?

I am using: Android version 7.0 on a Samsung Galaxy S7

1 Answer 1


I found a way to do this! (It's a bit fiddly).

  • Find your YouTube video
  • View the website in Desktop mode
  • Shorten the URL (using goo.gl)
  • Turn off Wi-Fi (so the shortened URL won't get to youtube.com)
  • Enter the shortened URL in your address bar on chrome
  • You should get a no internet error
  • Add that page to your home screen
  • Voila! Now enable Wi-Fi again and the icon will link to YouTube in your browser!
  • 2
    +1. Nice workaround, though I didn't try it out
    – beeshyams
    Jun 17, 2017 at 3:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .