I'm trying to root Kindle Fire but it always show "ADB status: Offline" when I start "run.bat". Could you help me out of this problem? :( I tried to plug, unplug, connect, disconnect the Kindle many times but nothing changes. I'm using Windows 7 x86.

  • Do you have the drivers installed? KFU comes with a file named install_drivers.bat that can do this for you. Commented Jan 1, 2012 at 19:37

3 Answers 3


I had the same problem with Kindle Fire Utility, and I actually figured this out.

The install_drivers.bat replaces the driver, which is not what you want! You need both drivers in place, the regular Amazon Kindle one, and the ADB driver. To get it to work:

  1. Uninstall the Android ADB driver in Device Manager (right click to do this)

  2. In Device Manager, right click the Kindle device and select "Update Driver Software", then point it to the included Kindle Fire Utility folder that has the driver /drivers/kindle

Then, it finally worked -- both drivers were in place -- then ADB showed up as online and I could get root, and do all the other stuff with KFU.


For those who tried many attempts in re-installing and rebooting but to no avail. This may be an alternative you can consider. This applies to those who ran install_drivers.bat and saw an error message regarding "./android/adb_usb".

This error is caused by our user name in windows which has one or more spacing (e.g. "Home User"). This one or more spacing breaks the batch file written to assist you in installing the relevant drivers.

Solution is simple, edit the install_drivers.bat and include double quotations (" ") to all file paths which has %userprofile% (line 9 & 10)

if not EXIST "%userprofile%\.android\" ( mkdir "%userprofile%\.android\" )
copy drivers\kindle\adb_usb.ini "%userprofile%\.android\adb_usb.ini"

Before re-installing your drivers, kindly ensure you removed the existing drivers via Device Manager -> Android Phone -> "Android ADB Interface" (or) "Android Composite ADB Interface"

Re-run install_drivers.bat and then run run.bat

Your kindle should be ready for rooting :)


IF you have run the install_drivers.bat file, and still have this.. Few things to do :

1) Reboot computer/Kindle 2) Re-install drivers through KFU 3) Re-install drivers manually.

  • and make sure it is "Android Composite ADB Interface", it won't work if it's "Android ADB Interface". Commented Jan 1, 2012 at 23:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .