I use WhatsApp on Genymotion. Chatting in the WhatsApp via Genymotion is fine, except, I wish to enable the WhatsApp web too, so I could free myself from bringing up the genymotion window all the time, instead, could just have all in my host machine browser.

To enable WhatsApp Web, it requires to scan a QR code generated on the web.

What I want to do:

  • Open web.whatsapp.com
  • Take a screenshot, crop the QR code only
  • Make the image available in Genymotion
  • Feed that image into the preview camera, which would be in turn available when I bring up the WhatsApp Web activation in WhatsApp.
  • The WhatsApp app would then think of the feed as coming live, thus enable the authorization.


I wish to feed an image to show in the Genymotion camera preview. How do I do that?

  • Which OS are you using?
    – xdevs23
    Mar 18, 2018 at 14:13
  • @xdevs23 I'm using Ubuntu
    – KhoPhi
    Mar 18, 2018 at 15:32
  • Then try the suggestion for Linux below. In case that does not help, trying other virtual camera software should help.
    – xdevs23
    Mar 18, 2018 at 16:34

6 Answers 6


I failed to get this working on Ubuntu 18.04. Here's what I found:

  • The Ubuntu repos contain a program called Webcamoid which can create a virtual camera that uses your desktops as the camera input.
  • However, the version of Webcamoid that's installed by sudo apt install webcamoid at time of writing (version 8.1.0+dfsg-7) dies with a segmentation fault. You can get around this by downloading from the webcamoid website.
  • To create a virtual camera with Webcamoid, you also need to install v4l2loopback, e.g., using sudo apt install v4l2loopback-utils.
  • The virtual camera will be created as /dev/video* (e.g. /dev/video0).
  • Even with all this, Genymotion does not detect the camera. I suspect it is looking for USB devices rather than just looking at /dev/video*. The Webcamoid wiki says, "If the programs detects the webcams by listing USB devices, the programs will be not able to detect the webcam, but it will be possible in a future."

So the answer on Ubuntu seems to be that it's not yet possible but may be in future. I suspect that any other Linux software that tries to create a virtual camera will run into this same issue.

Update 2020-03: I notice that the Webcamoid wiki now shows that development versions of Webcamoid support using akvcam as the virtual camera driver. I have not tested it, but their compatibility table suggests that many programs which did not find the camera using v4l2loopback do find it with akvcam.


I made it work using the 2010 Manycam version 2.6.1, since Manycam latest version has restrictions.

As you can note when scanning it (https://www.virustotal.com/gui/file/057cb7702e9ad97ee34f8d127d08699c11b6580a02c3f60500ecf4d345b141a4/detection) the software includes a toolbar. So, pay attention while installing to uncheck the toolbar installation.

The app tried to connect to Internet (perhaps was checking for updates, but I had no time to analyse it, I blocked it with my firewall without any use problem. Genymotion detected the cam as "webcam 1", open Manycam and you can use a still image with the QR as source.


If you are using Windows you can use something like Manycam to emulate a camera and provide it with any image you like (Source: https://softwarerecs.stackexchange.com/questions/36515/fake-virtual-camera-and-microphone-for-windows)

For Linux and macOS, you can use a progam like WebcamStudio (Source and Guide: http://marcelog.github.io/articles/android_emulator_linux_virtual_webcam_video_device.html)

In Genymotion you can then choose to use that emulated camera and there you go.


I managed to solve this problem in Ubuntu by using DroidCam. I believe it can work on Windows too. Here is a good tutorial on how to install it:



I just had the same problem and thus found this post. I managed to solve the problem (however simply by taking a picture with my phone of the QR-Code and scanning it in Genymotion by using the computer's webcam which was easily able to connect).

However, the next problem is, that in order to use Whatsapp Web (or, as I tried, using Franz), the "phone" needs to be connected to the internet, which it is not, when I close Genymotion, which was the reason why I wanted to do that.

Just in case anyone else finds this and has the same situation ;-)


Using Xubuntu 20.04 I got this working.

What you need for this is ffmpeg and v4l2loopback; they are both in apt. Be sure to modprobe and rmmod on v4l2loopback anytime you do anything to completely reset the dummy device. You can debug a bit with Webcamoid, which is less picky than Genymotion for the virtual device. The trick is the image or video (at the present version of Genymotion 3.2.1 in my case) must be 640x480. The developers said they are looking into this, but as of yet it is not available. You will then do something similar to the following (replacing /dev/video2 as needed for your Dummy)

ffmpeg -f x11grab -r 60 -s 640x480 -i :0.0+0,0 -vcodec rawvideo -pix_fmt yuv420p -f v4l2 /dev/video2

Now with this small resolution, you need to shrink the WhatsApp Desktop window as small as you can, hold down Alt to grab any part of the window with the mouse to keep moving it further, as even the top toolbar will need to be off the top of the screen...

The QR code appears in the upper left, the emulated device in Genymotion will easily see it (click the camera item and select this Dummy camera in the emulated device, it will show a preview), and you can enable WhatsApp.

As was stated, however, Genymotion needs to be running somewhere otherwise none of the messages will come through to the WhatsApp desktop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .