3

Since I upgraded my S7 to Nougat I notice that the syncing of my google accounts is particularly slow.

If on a computer I create a calendar event, or I send myself an email, I often do not see that as an Inbox notification, or reflected on my Google Calendar widget, until I actually open either app.

I guess (but I am not sure -- how about push notifications?) that this is related to the Google Account syncing being too slow, see attached below ("Sync Calendar", "Sync Gmail" and "Sync Inbox"), taken on 6/20 8:15am.

The things I already tried:

  • I do have continuous internet, tried switching between WiFi and 4G mobile internet, all work. I receive near-real time notifications for e.g. WhatsApp and Slack.
  • In Settings > Apps > Special Access > Optimize battery usage, I added the below to "not optimized":

    • Calendar
    • Calendar storage
    • Gmail
    • Google Play services
    • Inbox
  • In Settings > Device maintenance > Battery > Unmonitored apps, I added
    • Calendar
    • Inbox

bumped to the homepage by Community yesterday

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • 1
    This might sound silly but did you try turning the phone off and on again? If the Google Cloud Messaging service got broken in some way that might start it up again. – Dan Hulme Jun 23 '17 at 8:37
  • @DanHulme not silly, fair point and I wish that was the case, but even after a restart my sync times are a few hours behind. – Daniel Sparing Jun 23 '17 at 9:04
  • @DanHulme You know what, you were right in a way -- while turning the phone off and on did not help, turning sync (in the notification area) off and on did -- so while I am still puzzled by what caused this, the issue is gone. I wonder if I should delete this question now as no meaningful answer is expected. – Daniel Sparing Jun 25 '17 at 15:02
  • No, don't delete the question because then the information is lost to any future visitors. You should write what you did as an answer. – Dan Hulme Jun 25 '17 at 16:27
0

You can try to force account sync by manually resetting the time.

  1. On your device, open the Settings app.
  2. On "System", tap Date & time.
  3. DisableDate & auto time and Automatic time zone.
  4. Change the date and time manually to be incorrect.
  5. Tap the Home Screen button.
  6. Reopen the Date & Time settings.
  7. Change the date and time manually to be exact again.
  8. Activate Automatic date & time and Auto time zone.
  • To do a one-time sync, i can just switch that sync off and then on again. But what I need is the sync to continue in reasonably frequent intervals, or push notification. – Daniel Sparing Jun 23 '17 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.